WordPress.org

Ready to get started?Download WordPress

Forums

Vimeography
[closed] Vimeography Theme Compatibilty Inconsistency (10 posts)

  1. nsr2412
    Member
    Posted 1 year ago #

    I can't seem to get the Vimeography plugin to display correctly in my custom theme. For some reason it is just showing one massive video which expands to fill the containing div and no thumbnails are showing either. I tried all the suggested fixes such as adding [raw][/raw] tags to the shortcode, checking that wp_head() is called correctly etc. I even updated to jQuery 1.10 but to no avail.

    I did however notice that it works fine when I switch the theme to the default WP 2013 theme. Upon further inspection of the source code, I noticed that in my theme the plugin is loading an iFrame.

    See code below. (shortened for brevity)

    <div class="vimeography-main">
    <div class="vimeography-player">
    <iframe width="1280" height="720" frameborder="0" allowfullscreen="" mozallowfullscreen="" webkitallowfullscreen="" src="http://player.vimeo.com/video/46743041">........
    </iframe>

    but in the default theme it does not.

    See code below. (shortened for brevity)

    <div id="vimeography-gallery-2" class="vimeography-bugsauce" data-version="1.0">
    <div class="vimeography-main">
    <div class="vimeography-player">
    <div class="fluid-width-video-wrapper" style="padding-top: 56.25%;">
    </div>
    ..............

    Any help or clarity on this matter would be greatly appreciated.

    http://wordpress.org/plugins/vimeography/

  2. Dave Kiss
    Member
    Plugin Author

    Posted 1 year ago #

    Hey there,

    Can you provide a link to the page where you're experiencing the issue?

    Dave

  3. nsr2412
    Member
    Posted 1 year ago #

    Hi Dave,

    Thanks for your response. My apologies for not getting back sooner.
    Unfortunately I have not set up a test environment yet as I am working off of my local machine using MAMP. I am however in the process of setting up a test domain.

    Until I have something live, I can tell you that I am using the following WordPress framework theme based on Zurb's Foundation 4
    https://github.com/drewsymo/Foundation.

    Hope this could be of any help?

  4. Dave Kiss
    Member
    Plugin Author

    Posted 1 year ago #

    If you can, post a link when it is live. There are so many themes, so it is easiest for me to just look at the conflicting code.

    Thanks!

  5. nsr2412
    Member
    Posted 1 year ago #

    Hi Dave,

    I am in touch with my hosting provider and should have something up in the next 24 to 48 hours.

    Thanks so much for your prompt response.

    Have a great day.

  6. nsr2412
    Member
    Posted 1 year ago #

    Hi Dave,

    Apologies for the late reply.
    After a very frustrating week I have still not managed to get a test site live yet. Who knew it would be so difficult.

    Anyway, I am starting to get desperate with regards to finding a solution as to why the vimeography plugin is loading a massive iFrame and not showing the thumbnails.

    I am more than happy to send you my code if that would help any way.

    I think your plugin is really awesome and I would so like to use it on my site.

    Thanks again for your assistance.

  7. Dave Kiss
    Member
    Plugin Author

    Posted 1 year ago #

    Try checking your browser's javascript console for any errors it is reporting. That's usually a sign of a javascript conflict.

    Dave

  8. nsr2412
    Member
    Posted 1 year ago #

    It seems that the starter theme I was using was breaking quite a few plugins (including Vimeography). So I decided to swap out themes (I am now using Bones) and everything is working great.

    Thanks for a really awesome plugin.

  9. emiljonzon
    Member
    Posted 3 months ago #

    I fear I have the same problem as nsr2412

    Take a look at http://www.mariannelund.nu/wp/ga-pa-marre/bildgalleri/
    The first two videos looks great. The third one though, opens up a big iframe which mess up everything.

    Dave was referring to the "browsers javascript console", but I'm afraid I don't know how to follow that advice.

    I'd be glad for any kind of help!

  10. esmi
    Forum Moderator
    Posted 3 months ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

    I am now closing this 9 month old topic as it references an older version of WordPress.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic