WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Facebook: Advanced Sharing Optimization for All Social Websites
[resolved] Vimeo videos not playing inline on Facebook (11 posts)

  1. dagicueppers
    Member
    Posted 1 year ago #

    Hi all:

    The plugin is working beautifully for me: Titles, meta descriptions and thumbnails now show up perfectly on all platforms (Facebook, LinkedIn, Twitter and Pinterest).

    I have one last problem, and I just can’t figure out how to solve it: When I share any of the video posts on Facebook, they don’t start playing. The video player embeds, title, meta description and thumbnail show up, but when I hit the “Play” button, nothing happens.

    More info:

    The videos are hosted on Vimeo and embedded in the post via iFrame.

    The privacy settings on Vimeo for the videos are set to “public.”

    This also happens with videos and posts that have not been previously shared on Facebook, so the problem does not appear to be Facebook’s cache.

    The og:video" content="… " meta tags each point to the correct video on Vimeo.

    A sample for a video post on my website with the described problem is: Virtual Building Transbay Transit Center

    A screenshot of a video post how it shows up on my wall after sharing can be found here: Facebook Wall Video Post Preview

    I have found one discussion in a forum that may hold a solution. It suggests to include a ‘og:video:secure_url’ –tag. Is there a way to do that with this plugin? The discussion can be found here: StackOverflow

    Another suggestion I have found is to replace the URL of the embedded video with a (bit.ly) shortened URL. When I do that, the link on Facebook just turns into a regular link to my blog, ignoring the video content.

    My site is: Studio 7C and the blog is at Studio 7C Blog

    Has anyone else seen this problem? I would greatly appreciate any ideas how to fix it.

    Thank you very much in advance!
    My best,
    ~Dagi Cueppers

    http://wordpress.org/plugins/nextgen-facebook/

  2. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Ah. That *is* interesting... I guess this would be the logical evolution of Facebook offering https for it's pages. To avoid browser warnings (when serving pages with https), they must disable all non-https content.

    I see Open Graph has also been extended to support og:image:secure_url and og:video:secure_url meta tags...

    If you'd like to give the current DEV version (6.3-dev1) a try, you can download it here: http://downloads.wordpress.org/plugin/nextgen-facebook.zip

    I've added a new "Use HTTPS for Videos" option that is checked by default.

    Let me know if that fixes your issue. You should check the results on Facebook using both http and https -- just to make sure. ;-)

    Thanks,

    js.

  3. dagicueppers
    Member
    Posted 1 year ago #

    Thanks much for your quick reply, JS! I installed the developer version and that did not fix my problem. I appreciate your help very much, though.

    I've done a lot of research in case you are interested in what I found. Many pieces of information, none of which have caused my embedded videos to play:

    Turning off secure browsing on Facebook doesn't solve the problem.

    Vimeo does not offer ssl support for embedded videos at this time. They suggest replacing the 'http' in the embed code with 'https'. Doesn't work for me and a lot of other people.

    I also found a source saying that Facebook currently ignores the "og:secure_url" -tag when video is posted from a third-party app. They suggest posting the URL directly into Facebook as a workaround...

    I don't like it, but it might be time to settle for the bit.ly link version.

    Thanks much for your interest and help. And for the awesome plugin, of course!
    ~Dagi

  4. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Using HTTPS when calling Vimeo's API returns HTTPS urls, which seem to work just fine.

    The Like/Send/Share buttons are not "applications" -- they basically just send the URL to Facebook and don't fall into the "3rd party app" category.

    I've tested this myself and it works just fine. Have you tried the DEV version with a new video? It worked for me. ;-)

    You can also use the 'Validation Tools' tab on a published Post/Page to check what Facebook sees.

    js.

  5. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Dagi,

    Is everything ok now, or are you still having issues?

    Thanks,

    js.

  6. dagicueppers
    Member
    Posted 1 year ago #

    Oh, you're wonderful! Thank you so much for checking in. It's a little crazy to admit it, but I've been trying to figure this out all day. Can't let it go now that you made it work. But so far, no luck. Both the Facebook Debugger and the Google Structured Data Testing Tool now attest that the blog is finally outputting the HTTPS version, but Facebook still doesn't play the video. I followed your recommendation, of course, and tried a newly uploaded video in a new post, but that didn't do it. I'll let you know when I figure it out.

    Thank you so much, JS!
    ~Dagi

  7. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Try a new page with a new video -- once something is shared on Facebook, you can't change it, even after updating the content and refreshing Facebook's cache with the debugger.

    js.

  8. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Any update? Let me know if I can be of assistance.

    Thanks,

    js.

  9. dagicueppers
    Member
    Posted 1 year ago #

    Thank you so much, for checking in, JS. I finally gave up on the idea of my videos playing inline on Facebook when shared from my blog.

    The problem is not the Facebook cache. I have tried with dozens of newly uploaded videos and newly created posts.

    Any YouTube video embedded and played fine, privacy-enhanced mode on or off, with and without secure browsing enabled on Facebook. For that reason, I'm not sure anymore that the problem is related to secure browsing or SSL support, but Vimeo confirmed that they will start offering SSL support with their next player release and I'll try again when they do.

    Strangely, it also worked flawlessly with the old Vimeo embed code. (http://vimeo.com/moogaloop.swf?clip_id=...) I don't want to use it; just tried it to find out what's working and what isn't...

    I don't know what my conclusion is other than that I don't have any more time to try to figure it out. For now, I have beautiful titles, descriptions and thumbnail images for all of my posts, thanks to your awesome plugin. Thank you for all your work and help. I will rate and review the plugin right now.

    Thank you very much, JS!
    ~Dagi

  10. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Well, I haven't given up so far. ;-)

    I did a major re-code of the video stuff this morning, and noticed Vimeo does not provide a "flash" URL in it's API -- which Facebook needs. I uploaded a video to Vimeo, then passed it through the FB debugger to check meta tags:

    https://developers.facebook.com/tools/debug/og/object?q=https%3A%2F%2Fvimeo.com%2F71092218

    That URL to 'megaloop.swf' is not provided by their API. :-( So, I only used some information from the API, and hard-coded the 'megaloop.swf' URL. Hopefully this should solve the issue.

    Download the latest DEV version from http://downloads.wordpress.org/plugin/nextgen-facebook.zip, and let me know if that fixes your issue. ;-)

    js.

  11. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Dagi,

    I'm going to close this thread since the issue has been resolved in v6.4. If, for some reason, you're still having difficulties, just post a follow-up and I'll be happy to assist.

    Thanks,

    js.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic