WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Viewing WPFullCalendar Weekly Agenda (12 posts)

  1. generic0
    Member
    Posted 1 year ago #

    I'm using WP FullCalendar with Events Manager - the default view of the calendar is set to Weekly Agenda.

    When the page is viewed any events that start at 5:00am can not be seen, you have to scroll the calendar up to see them. Is there any way to set the agenda up so the 5:00am event is seen without scrolling?

    Also the calendar is set to display #_EVENTTIMES #_EVENTNAME, what is displayed on weekly agenda is the start time at the top in a dark background, followed by the event times and the event name in a light background - is there a way to remove the start time at the top in the dark backgounnd - that does not seem to be controlled in the settings and I can not seem to find any styles for it.
    Thanks!

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 1 year ago #

    Hi,

    yes, you can used css styling to change it's height; please see WP Settings > WP FullCalendar > Load JS and CSS files on

    to view the default fullcalendar css, wp-content/plugins/wp-fullcalendar/includes/css/ui-themes

  3. generic0
    Member
    Posted 1 year ago #

    Sorry I must not have explained my question well. The Load JS and CSS files on that you reference is to load those files only on specific pages... but that's not what I'm asking... or is it?

    On the weekly calendar when you have the calendar set to "weekly agenda" the calendar for some reason does not show an event that starts at 5:30am, you have to scroll UP to see the event. What the client would like, me as well, is to see the 5:30am event without having to scroll up. How would that be adjusted... it looks like something somewhere has set the agenda to start showing events at 6:00am not before.

    Here is a link: http://susanwellerdesignstudios.com/townefitness/class-schedule/

    As far as how the Weekly Agenda displays the time twice, are you saying that I can make that adjustment in the jQuery CSS theme - I want to set that first tab to "display/none". I can't see what I need to see using Firebug...

    Thank you

  4. generic0
    Member
    Posted 1 year ago #

    Nevermind about the 2nd issue - figured that one out - just had to remove the Time Format in the WPFC setting -- so if I can just get the calendar to show the 5:30am dates I should be all set! :)

  5. agelonwl
    Member
    Posted 1 year ago #

    Hi,

    so if I can just get the calendar to show the 5:30am dates I should be all set! :)

    you can try my answer here - http://wordpress.org/support/topic/supressing-times-listed-on-weekly-agenda?replies=2

  6. generic0
    Member
    Posted 1 year ago #

    agelonwl - even when I remove the unnecessary hours (my other post - thank you!) the calendar still needs to be scrolled UP to see the 5am classes - I haven't been able to find where to change that - it must be a settings somewhere but I just don't see it - do you know where that setting is?

  7. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    you may need to add another argument to the fullcalendar file like in your other comment, see this:

    http://arshaw.com/fullcalendar/docs/display/aspectRatio/

  8. generic0
    Member
    Posted 1 year ago #

    Thank you Marcus...

    I found what looks like the right argument - called "firstHour"

    http://arshaw.com/fullcalendar/docs/agenda/firstHour/

    Where do I add this?

    I copied the text from that page - just changed the 6 to 5 - and added it to the wpfc-events-manager.php in the var fullcalendar_args = {

    but that wasn't right - the calendar didn't even display.

  9. agelonwl
    Member
    Posted 1 year ago #

    try this steps:

    1. edit wp-content/plugins/wp-fullcalendar/wp-fullcalendar.php

    2. search method - function footer_js(){

    3. below var fullcalendar_args = { add this line minTime:'5',maxTime:'21',firstHour:'5',

  10. generic0
    Member
    Posted 1 year ago #

    Perfect! Thank you so much agelonwl, I really appreciate all your help!

  11. dsg257
    Member
    Posted 1 year ago #

    calendar does not load when I put in the code
    this is what it looks like

    var fullcalendar_args={
    minTime:'5',maxTime:'21',firstHour:'5',
    timeFormat: '<?php echo get_option('wpfc_timeFormat', 'h(:mm)t'); ?>',

    when code is inserted the page with the calendar is blank

  12. angelo
    NetWebLogic Support
    Posted 1 year ago #

    can you re-post this in a new thread please? also, what is your wp fullcalendar version?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic