WordPress.org

Ready to get started?Download WordPress

Forums

Viewing Pages (NOT POSTS) (6 posts)

  1. akinoluna
    Member
    Posted 4 years ago #

    I can't view my pages, I can only edit them. When I click on the page link it just refreshes the index page, though it does include the page name in the url. Does anybody know what I need to do to make them viewable? (And yes, I have the widget active)

  2. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    Please post a link. What widget?

  3. akinoluna
    Member
    Posted 4 years ago #

    The sidebar widget that shows links to all the pages.

    Index page:
    http://www.akinoluna.com/blog/

    The widget I was talking about is at the top. If you click on the female Marine link, hopefully you will see what I'm talking about: the url is this -

    http://akinoluna.com/blog/female-marines-101/

    ...but instead of the page content (which is just two placeholder words) I just see the index page again.

  4. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    Your site does have lots of errors which may contribute to your problem. Errors are cascading so if you fix one sometimes several go away. You also have some bad links which are probably caused by the html errors. In WP always use a complete URL for a link. The Codex also will give you some information about pages.

    What permalink setting are you using? And is your .htaccess file writeable.

    Broken or bad links, http://validator.w3.org/checklink?check=Check&hide_type=all&summary=on&uri=http%3a%2f%2fakinoluna.com%2fblog%2f

    HTML errors, http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2fakinoluna.com%2fblog%2ffemale-marines-101%2f

    Codex, http://codex.wordpress.org/Pages

  5. akinoluna
    Member
    Posted 4 years ago #

    Only one of those link errors should have anything to do with the broken pages and I took it out, it was just an attempt to link to the page in question.

    The permalinks are set to month and name and they've always worked fine, I can change them around without any problems.

    It appears that my htaccess file is writable but after upgrading the permissions to the entire world and publishing new pages, it doesn't change and the pages still don't appear.

    This is what's in it, if it helps:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    # END WordPress

  6. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    The htaccess looks ok to me. This is your hmm page, http://akinoluna.com/blog/female-marines-101/page/2/

    It looks to me like the permalinks are messed up or maybe having pages tied back to blogger is a problem.

    The normal procedure is to go back to default permalinks, deactivate all plugins, go to default theme and see if it works. The restore one thing at a time until it breaks again.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.