WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] View Site logs me out? (10 posts)

  1. zero360
    Member
    Posted 6 years ago #

    Just upgraded to 2.3.1... I login (admin) and can write, configure, etc. but when I click View Site, I'm no longer logged in and see the blog as if I'm just hitting the URL as a new browser instance, therefor I don't see Private posts. If I click login, howver, I'm right back in admin mode without being prompted for username/password.

    Before upgrading I would stay logged in (as admin) when I'd click View Site. I'm a WP novice and appreciate any and all help.

  2. Samgreen
    Member
    Posted 6 years ago #

    I right click the 'viewsite' link and select 'open in new window'.

    its not logging you out, you should be able to go back, by clicking the 'back one page' button, it is dispaying your site.

  3. zero360
    Member
    Posted 6 years ago #

    Hi Sam... right, I'd tried this, but same issue, I want to see "Logout" in the Meta panel, not "Login".

    Seems to me the authentication is not staying active between views. I'm just not savvy enough to know which knob to turn.

  4. Samgreen
    Member
    Posted 6 years ago #

    Oh, thats because you still have the login cookie.

    Exit all the way out of your browser, and if you have it set to delete cookies upon exit ( I do this in firefox) when you bring your browser back up the auto-login wont happen/wont be there.

    edit: I just looked at my blog. And I don't have the 'meta' part in there anymore.

    But if you go back to the dashboard, the 'logout' link is there. Click it and the session cookies should go away.

    I still suggest exiting all browser windows/tabs when you are done working on your blog.

  5. zero360
    Member
    Posted 6 years ago #

    I must not be explaining my desired state correctly: I WANT to stay authenticated/logged in when I view the site instead of having to re-login each time I toggle between admin mode and the blog itself.

    Thanks!

  6. Samgreen
    Member
    Posted 6 years ago #

    I understood your first post to be that it wasn't logging you out when you wanted to.

    But I see now you want to go back and forth between making changes and viewing the site to see if the changes took.

    okay. Here is what I do.

    I log into the admin section.

    I make changes to my blog.

    When I want to view the changes, I don't exit my blog. I don't left click on 'view site'.

    I right click on 'view site' and open it in another browser window, to see what readers see.

    I make note if it doesn't look like I wanted.

    I then select the other browser window and make changes. Save them.

    Then I select the other browser window, the one that displays what readers see, and verify the changes are there. Refresh that window if I need to.

    Or you could have what readers see in another tab.

    If you have the two windows or two tabs, it doesn't matter what the meta shows.

  7. zero360
    Member
    Posted 6 years ago #

    path issue... thanks

  8. Lambda1234
    Member
    Posted 6 years ago #

    Mind sharing what the issue was and how you resolved it? I'm having a similar problem. Thanks!

  9. Lambda1234
    Member
    Posted 6 years ago #

    Never mind, I'm good now. My fix had to with resetting the values in the WordPress address and blog address fields on the options > general page. I don't know why these values would have been broken in the upgrade process, but resetting them (IE changing them to something else and then changing back) seemed to help the process.

  10. Samgreen
    Member
    Posted 6 years ago #

    you're welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic