WordPress.org

Ready to get started?Download WordPress

Forums

Quark
[resolved] View Full Width Posts without Sidebar (12 posts)

  1. vagabondish
    Member
    Posted 1 year ago #

    Hello,

    I am working with the Quark theme, version 1.2.4. There doesn't seem to be a way within the dashboard to have individual posts display full-page without a sidebar. I'm fine having the sidebar display on the blog page with the lists of posts, but when I click on an individual post, I don't want to see the sidebar.

    Thanks in advance!

    Russ

  2. ahortin
    Member
    Theme Author

    Posted 1 year ago #

    Hi Russ,

    You're correct. That's not something that's currently built into the theme, but it's super easy for you to change it to do that.

    Within single.php, simply change the line that says...

    <div class="col grid_8_of_12">

    to...

    <div class="col grid_12_of_12">

    After that, also delete the following line...

    <?php get_sidebar(); ?>

    Hope that helps.

  3. vagabondish
    Member
    Posted 1 year ago #

    ahortin, Thanks, this worked well. The issue I have now is that my media is still sized based on a sidebar format, so that the featured image does not resize to the full width of my post. Any simple solutions for this?

    Thanks again!
    Russ

  4. ahortin
    Member
    Theme Author

    Posted 1 year ago #

    That's fairly easy to fix as well. Around line 51 in functions.php, change the values in the following line...

    add_image_size( 'post_feature_full_width', 792, 300, true );

    The two numbers in that line are the width (792) and height (300) of the Feature Image. Simply change that to whatever width you'd prefer.

    After doing that, install the Regenerate Thumbnails plugin and regenerate the thumbnail images for all your previously uploaded images.

    After you change the above line in functions.php, any new image you upload will automatically get cropped to the new size that you've specified. This plugin will simply regenerate the images that you've already uploaded.

  5. vagabondish
    Member
    Posted 1 year ago #

    Thank you so much!!

  6. Muehlenweg
    Member
    Posted 1 year ago #

    Hi Anthony,

    I had the same issue and getting rid of the sidebar worked well. Afterwards I changed the featured image size to 1200x454 in the functions.php, then ran Regenerate Thumbnails.

    The latter did not change the featured image though, in fact my image wasn't even shown at 792 (the original specs) width, but instead at 628 px width (which might have to do with the original image size). When I upload a completely new image, it shows up fine. Is there anything on existing images I can do, or is it easier to dump those and just upload them from scratch now?

    The other issue I got after removing the sidebar on single posts is that any text I had between images now jumped up and put itself next to the first regular image of the post (which is 792 px wide), as if it's using the "empty sidebar" now. So instead of seeing some text, then 5 images stacked, then more copy, then some images etc, I now have the copy that was supposed to be between the first and second batch of images on the right side of the first image (where the sidebar normally is). How do I get rid of that and get the text back down?

    Thanks!

  7. Muehlenweg
    Member
    Posted 1 year ago #

    I realized I didn't do the Regenerate Thumbnails properly, so that issue is fixed now, just need to know how to fix the text jumping up now.

    But apart from that, what media settings are you recommending for your theme by the way? The WP settings where not changed when I activated your theme, so I changed them to this:

    Thumbnails: 250 x 250
    Medium Size: 792x0
    Large Size: 1200x0

    Would you adjust anything to make it work better within the grid/design?

    Thanks!

  8. ahortin
    Member
    Theme Author

    Posted 1 year ago #

    Glad you sorted out your "regenerate" issue.

    As far as image sizes go, that's entirely up to you and the content that you're adding. There's no set sizes for those settings that are better or worse. The blog posts use a custom image size, mentioned above, of 792 x 300px (defined in functions.php). If you want to change this image, you'll need to make the same change as I mentioned above, in my reply to Russ.

  9. Muehlenweg
    Member
    Posted 1 year ago #

    Thanks so much Anthony!

    I realized that my iPhone showed that extra white space because of that long word in the headline. Will make sure to use shorter words now ;)

    Can you look at the link below? I still haven't been able to fix what I mentioned above:

    'The issue I have now have the copy that was supposed to be between the first and second batch of images now shows up to the right of the first image (as if it's trying to use the empty sidebar). How do I get rid of that and get the text back down?'

    http://batesvision.com/2012/08/october-26-28-3rd-british-natural-eyesight-conference-reserve-your-space-now/

  10. ahortin
    Member
    Theme Author

    Posted 1 year ago #

    Remove the alignment from the images and your text should go back to where you've added it. At the moment they're aligned left. Change them so they are not aligned. Either that, or change them so they are aligned center.

  11. Muehlenweg
    Member
    Posted 1 year ago #

    You rock Anthony!

    I have a few other problems but will try all night and only bother you again if I really, positively, absolutely cannot figure it out myself...

  12. ahortin
    Member
    Theme Author

    Posted 1 year ago #

    No probs :-)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic