WordPress.org

Ready to get started?Download WordPress

Forums

WP Mobile Detector Mobile Plugin
[resolved] View Full Site not working for me either, but use too (9 posts)

  1. swalker1974
    Member
    Posted 1 year ago #

    I built a custom theme with WP Mobile Detector. The 'View Full Site' link use to work, but the server the site was previously on was recently migrated to my company's servers (not sure if that's the cause). Before the migration, the switch link worked fine. I even tried using a default theme, thinking my theme was broke, but it still did the same thing. I even down graded the plugin, and also un-installed and re-installed it with no avail. The View Full Site link just keeps refreshing the mobile page it's on.

    Any help would be appreciated. Otherwise, great plugin!

    The domain is: http://www.drhainer.com

    http://wordpress.org/extend/plugins/wp-mobile-detector/

  2. websitezcom
    Member
    Plugin Author

    Posted 1 year ago #

    Do you use a cache plugin? Are you using a new desktop theme?

    Have you tried clearing your cookies?

  3. swalker1974
    Member
    Posted 1 year ago #

    No, I'm not using Cache plugin, and I have cleared my cookies

  4. Nowell VanHoesen
    Member
    Posted 1 year ago #

    I can confirm that the 'View Full Site' link doesn't change the display on a Samsung Galaxy S III using either Chrome mobile or the default pre-loaded browser.

  5. websitezcom
    Member
    Plugin Author

    Posted 1 year ago #

    Which theme are you using for desktop? You don't have anything else installed that may be detecting mobile do you?

  6. mjg7876
    Member
    Posted 11 months ago #

    Sorry to dig up an old post, but we are having the same issue. When you click the "View Full Site" link, it reloads the page, but it is still the mobile. However, if you then hit refresh in the browser, the full site will load like it should when you click the link. I see that your plugin is changing a cookie setting, but not sure why it isn't reading it correctly on the first reload. I will look through your code to see if I can pin point the issue, any ideas on where to look would be great. FWIW, we are using one of your mobile themes, and then a custom theme for the desktop. W3 Cache is installed, but tried with and without it and have the same result. We have also tried it on about a dozen devices, and the results are the same. I will post my findings, if I find it.

    Thanks

    Gudy

  7. esmi
    Forum Moderator
    Posted 11 months ago #

    @mjg7876: As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  8. mjg7876
    Member
    Posted 11 months ago #

    sorry, it wasn't marked resolved; that is why I added to it. I will post a new one.

  9. websitezcom
    Member
    Plugin Author

    Posted 11 months ago #

    @mjg7876: Please see this blog post: http://websitez.com/how-to-get-w3-total-cache-mobile-plugins-to-work/

    If you're still having issues, open a new thread and I will help you there.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.