WordPress.org

Ready to get started?Download WordPress

Forums

Video Embed & Thumbnail Generator
Videos showing up as DivX? (8 posts)

  1. courtneytrouble
    Member
    Posted 1 year ago #

    I am a big lover of this plugin, but recently something has gone buggy.

    The thumbnail's not showing up, it flashes something quickly about MIME, and then opens the video up in a DivX player!!!

    Man, I HATE DivX.

    Is there a fix?

    Kyle, you have helped me before, hopefully you'll know what's going on this time!

    Thanks!

    http://wordpress.org/extend/plugins/video-embed-thumbnail-generator/

  2. Kyle Gilman
    Member
    Plugin Author

    Posted 1 year ago #

    It's working fine for me on the free side. Is there a problem with the members only section? (assuming you're still talking about the same site) What browser are you seeing the problem in?

  3. courtneytrouble
    Member
    Posted 1 year ago #

    yes - it's happening on the member's side. i am using firefox. use ct/girlfag42 to log in to members. (also, consider that a tip!! haha!)

  4. Kyle Gilman
    Member
    Plugin Author

    Posted 1 year ago #

    It's related to the structure of your site. Firefox can't play mp4/m4v videos without Flash. The plugin uses swfobject.js to create the Flash video objects. In the members area of your site, it's looking for swfobject in /members/wp-includes/js/swfobject.js but can't access that file, either because of security settings or because it doesn't exist. So Flash isn't being loaded and apparently on your computer Firefox tries to use DivX to play back videos it doesn't support. The error message you briefly see is "No video with supported format and MIME type found"

  5. courtneytrouble
    Member
    Posted 1 year ago #

    ok. i took a look on ftp, and swfobject.js exists with permissions 777. is there something i can do to make flash work again? should i delete and re-install your plugin?

  6. Kyle Gilman
    Member
    Plugin Author

    Posted 1 year ago #

    You'll have to figure out why /members/wp-includes/js/swfobject.js is inaccessible to the public. Try going directly to it through http and you'll get a Page Not Found error. It might have something to do with your .htaccess in the /members directory or the way redirects are set up.

  7. courtneytrouble
    Member
    Posted 1 year ago #

    Kyle,

    OK. I'll look into it and post back if I get it to work on Firefox. Strangely enough, it works fine on Chrome. I'm making sure my own Java and Flash plugins are up-to-date before digging into my FTP again. I'll report back for future users. (i'm going to delete that login up there lest someone figures out what site we are talking about!)

  8. Kyle Gilman
    Member
    Plugin Author

    Posted 1 year ago #

    Yeah, it should work fine in Chrome and Safari, on mobile browsers, and probably in IE because they support H.264 playback without Flash.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags