WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Maximum video width reduced with 3.5 (3 posts)

  1. tlowl
    Member
    Posted 1 year ago #

    In previous versions of WordPress, I had set the maximum width of auto-embedded videos to be 590px. It worked perfectly.

    Now that the ability to set the maximum width has been removed, my videos have reverted to a smaller width. I don't believe that the new version of WordPress is auto-detecting the max width as advertised.

    Other than specifying the video width using short code EVERY TIME from now on (not to mention the 100 posts that I'd have to go back and look at), is there anything that can be done to set the maximum width of all videos?

    Website: http://owlandbear.com

    Example of video that was once 590px based on media settings, but isn't anymore with 3.5 update: http://www.owlandbear.com/2012/11/09/video-the-sea-and-cake-harps/

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 1 year ago #

    WordPress doesn't "auto-detect" the width, it expects the theme to tell it what the correct width actually is. The $content_width has been around for 3 years or so now, and any theme that has been made in that time should be implementing it properly.

    If your theme doesn't implement it properly, then you can add it like so:

    In the theme's functions.php file:

    global $content_width;
    $content_width = 123;

    Where "123" is the number of pixels wide that the main "content" area is for the theme.

  3. tlowl
    Member
    Posted 1 year ago #

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic