WordPress.org

Ready to get started?Download WordPress

Forums

Video Upload Not Working (6 posts)

  1. backpages
    Member
    Posted 5 years ago #

    I'm using 2.7 installation of WordPress on my own servers. When I try to upload a short video (QuickTime .mov) everything seems to proceed correctly. The uploader goes through it's little "crunching" animation and all seems good. But when it's finished only the name of the video has been placed in the post. No actual video is placed in the blog post. If I go to my library the video is listed there. What am I doing wrong? I just want to embed the video in my blog posting. Thanks for any help!

  2. Dora Crow
    Member
    Posted 5 years ago #

    I'm having the same problem. My WordPress is using the Sliding Doors theme, and is hosted by Network Solutions. I can upload my video, which is a .wmv and now says .wmv video/asf at the end of the name. But.. same as you - I can see it in my Gallery, but if I add it to my post, just the title is added. No video.

    I can successfully embed a YouTube version of my video in the HTML section of the "add new post", but would I prefer to upload my own copy, as it should be a much better quality video.

    Hopefully someone out there can help us - in the meantime.. maybe you could upload your video to YouTube, and then copy the embedding code from YouTube into the HTML section on adding a post in WordPress.. for now.

  3. Saurus
    Member
    Posted 5 years ago #

    I can successfully embed a YouTube version of my video in the HTML section of the "add new post", but would I prefer to upload my own copy, as it should be a much better quality video.

    That would be incorrect. having people view a video from the SOURCE will give better quality. Each time a video is downloaded and uploaded, it loses quality To say nothing - if you upload to your host - of the fact you are using YOUR bandwidth rather than the original source.

  4. withinsight
    Member
    Posted 5 years ago #

    I have local versions of WordPress 2.7.1 and WPMU installed, and I'm experiencing the exact same issue with both. I've got my upload_max_filesize in php.ini set high enough, and the 'Max file upload size' in the WPMU admin panel set to '99999999' to remove any size restriction error. This is definitely an issue.

    Is the WordPress video player part of the standard WordPress install, or are their additional steps required to get video running locally?

  5. figaro
    Member
    Posted 5 years ago #

    I've got my upload_max_filesize in php.ini set high enough,

    What about your post_max_size? That needs to be set in php.ini as well. Also, your max_execution_time and memory_limit may need to be increased.

  6. Matt
    Member
    Posted 5 years ago #

    Same problem as original poster. File goes up fine, but the only thing that gets inserted into the post is the file name... whatever.mp4. Not even hyperlinked to the file.

    Here's what you need to do: upload the file; open the kitchen sink in the toolbar; click the embed button; paste the URL of the file; enter dimensions.

    Looks like WordPress isn't very video friendly even in 2.7.x version. Sigh.

    (If you think it is php settings in your case, check if the video gets uploaded to your uploads folder. If it does, it's not php settings.)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags