WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Video format not available (8 posts)

  1. design_studio
    Member
    Posted 12 months ago #

    Video format is not available for selection when writing a new post.

    I was using the previous beta and twenty twelve theme and have created couple of video post. After update to version 3.6-RC1-24717 I decided to change one of them to general format and since then the video format option is not available at all. The strangest part is that when I open and edit existing video format post, that option is there.

  2. esmi
    Forum Moderator
    Posted 12 months ago #

    I'm using the same WP version and I can see all of the post format options just fine. Remember that they've moved back to the right-side column again. Also ensure that "Format" is checked in your Screen Options.

  3. design_studio
    Member
    Posted 11 months ago #

    I know where the options are. As you can read the last sentence in my post..."The strangest part is that when I open and edit existing video format post, that option is there.". I have all other format options but not the video one.

  4. esmi
    Forum Moderator
    Posted 11 months ago #

    Fairy nuff. It's just that when the new post format UI was yanked, it caught some people by surprise. What happens if you switch to Twenty Thirteen?

  5. design_studio
    Member
    Posted 11 months ago #

    Thanks for your response again. I haven't tried that but will do now. I think you are right as in the beta which I used it was still known that the post format UI will be there. What I notice however is if I copy a working video code from another post which I didn't changed to a new post with that video format option missing is that the code doesn't work. Strange because it is actually working in the other post! And cheking the output code - actually all the video part is there but not accessible, hidden between <!-- video -->

  6. design_studio
    Member
    Posted 11 months ago #

    Just an update:
    I switched to Twenty Thirteen - video option is available everywhere, even some extra formats. The post where I copied only the video code now is working and is recognised as video format post. When I add new post all the format options are availablle including the video one.
    When I switch back to twenty twelve, the post where I copied only the video code is showing as video post format! (after the change to Twenty Thirteen) but when I try to add new post - no video format option!.
    I can only see Standard, Aside, Image, Link, Quote and Status options.

  7. esmi
    Forum Moderator
    Posted 11 months ago #

    OK - that makes sense. 2012 only supports the 'aside', 'image', 'link', 'quote' & 'status' formats whilst 2013 supports far more. So it's more of a theme issue - or theme "feature" really. This variation in support from theme to theme is why there was an attempt to bring basic post format support into core. With luck, the promised new post format plugin will address this shortfall.

  8. design_studio
    Member
    Posted 11 months ago #

    Ok, now I see. I haven't looked at it from that point. But it is still strange that video posts created with the 3.6 beta and 2012 are still visible and clearly there is video format option visible and activated.
    Anyway, thanks for making this clear. Hopefully the new post format plugin will really do the trick.

Reply

You must log in to post.

About this Topic