WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Video files as links only (12 posts)

  1. pavforall
    Member
    Posted 1 year ago #

    Hi,

    I send MOW or 3GP files and they are added to blog as a links only (that you can click and then file is opened)
    How to get them added to use templates? I setup template however it looks like this configuration is not even considered.

    Regards
    Pawel

    http://wordpress.org/extend/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Please send a sample email with these file types to postie-test@devzing.com and I will see what is going on.

  3. pavforall
    Member
    Posted 1 year ago #

    Hi Wayne,

    Replied via mail.
    Cheers
    Regards
    Pawel

  4. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    The *.MOV files are coming through as video/quicktime so you'll need to add "quicktime" to the list of "Video 1 file types"

    The *.3GP files are coming through as application/octet-stream and so are being treated as a standard attachment. I.e. not a video file. You will need to change your system so that it attaches the file as one of the video mime types.

  5. pavforall
    Member
    Posted 1 year ago #

    wel... I added quicktime and now the post is added without
    attachement :(

    by telling "change your system" you mean modify postie or how viedo are created?

    thanks
    Regards
    Pawel

  6. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    >I added quicktime and now the post is added without attachment

    Please turn on debug logging as described here:
    http://postieplugin.com/enabling-debug-output/

    And send the log file to postie-help@devzing.com

    >by telling "change your system" you mean modify postie or how viedo are created

    No, I mean your email client needs to be told somehow what the correct mime type is of *.3GP files.

  7. pavforall
    Member
    Posted 1 year ago #

    Hi,
    debug is good opton. I found the issue, lack of space in the Video 1 file types. All good for quicktime.

    I tried adding applicatio to supported mime types and octet-stream to Video 1 file types however it does not help.

    Could you please suggest what needs to be modifed (hope not postie files) to support 3GP? The file i am tryign to send is Blackbery vido file (no sure why it is recognized as applicatio/octet-stream).

    Thanks
    Regards
    Pawel

  8. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Currently Postie will only process files that are of type video/* as video files. I will need to look at the attachment processing code to see if there is a more flexible way to handle video attachments.

    You need to find a way to convince your email program to attach the file using a video mime type.

  9. pavforall
    Member
    Posted 1 year ago #

    Hi Wayne,

    I added following code into postie-functions.php after line 826 in the last version:
    if (preg_match("/.3GP\$/i", $part->d_parameters["filename"])) {
    $part->ctype_primary = "video";
    $part->ctype_secondary = "quicktime";
    }

    and it works as a charm:)

    let me know if we could get this in standard release?
    Maybe you could add to postie functions some hook that could be called
    from custom plugins and filter these values?

    Thanks for all help
    Regards
    Pawel

  10. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the code and idea.

    I am thinking about adding a filter option so that people can pre-process the attachments in their own code.

    I'm also looking at dealing with attachments differently to deal poorly set mime types like you are experiencing.

  11. pike67
    Member
    Posted 1 year ago #

    I have the same issue; sending mov files from a phone. I cant really change the file name.

    The headers in the mail I send say

    --------------020802000001030200030108
    Content-Type: video/quicktime;
     name="IMG_0179.mov"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
     filename="IMG_0179.mov"

    I've added 'quicktime' to the video1 list .. didnt help. 'mov' is already there.
    what exactly is it looking for ?

    curious,
    *-pike

  12. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Please send a sample email to postie-test@devzing.com and I'll see what is going on.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags