WordPress.org

Ready to get started?Download WordPress

Forums

Visual Form Builder
[resolved] VFB - WP Mail SMTP Configured Correctly, Form Still Errors Out (3 posts)

  1. johnevanofski
    Member
    Posted 1 year ago #

    Hey there,

    I'm also on Bluehost, it looks like there have been some issues with other people using Bluehost. I don't know if you've had any new information on the problem. Here's how far I've gotten.

    I configured WP Mail SMTP and the test emails are working fine. I am able to send the test emails successfully using both the 465 and the 26 ports through Bluehost's SMTP mail.johnevanofski.net . I have tried using both: Send all WordPress emails via SMTP and Use the PHP mail() function to send emails to no avail. :(

    Your email form is the best on WordPress and I'd be so sad if I wasn't able to use it. Hopefully this is something you can fix, I'll totally go pro if you can. Thanks!

    Here's a link to the contact page in question

    Thanks!

    http://wordpress.org/extend/plugins/visual-form-builder/

  2. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Bluehost, Dreamhost, Go Daddy. These seem to be bigger offenders to wp_mail than most other hosts.

    WP Mail SMTP will get you part of the way there. The next step sorta depends on your host and how things are configured within Visual Form Builder.

    The only thing I know of to suggest is that you set the "Reply-To" email as an email from the same domain as your site AND that it exists in your cPanel (as in, you created this email through their domain admin interface on your site). Go Daddy seems to choke on the line endings in the headers if they aren't set a certain way( \n compared to \r\n). That last one is something I have to pick my battles on - I opted for the recommended RFC standard.

    If that doesn't work, you can try checking out some of the recommended server settings and see if that helps.

    I hope that gets you to where you can use the plugin.

  3. johnevanofski
    Member
    Posted 1 year ago #

    Wow!

    Thank you so much for your quick reply. Changing the Reply-To Email to the email on my server totally fixed it, I'd had it blank before.

    You are the best

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic