WordPress.org

Ready to get started?Download WordPress

Forums

Visual Form Builder
[resolved] VFB Pro XML error when exporting entries (13 posts)

  1. yasamadair
    Member
    Posted 1 year ago #

    Hi Matthew. I've just purchased Visual Form Builder Pro in order to export my entries to .xls file. But I get xml error about datetime data cell (ex.: 2012-12-13 19:41:09). I changed timestamp at class-export.php as warptimer said above but that didn't work :( Urgent help please!

    http://wordpress.org/extend/plugins/visual-form-builder/

  2. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    I've been working on the export (as seen in the latest release of the free version). The Pro is next (no timeline for release).

    The DateTime format is in the correct format. There's no need to add a 'T' as it's already there.

  3. yasamadair
    Member
    Posted 1 year ago #

    Yes, you're right. DateTime was okay. I put a space instead that T but this didn't work. As a quick solution, I edited xls file at notepad (by adding "T" between date and time) and saved. Then I opened it with Excel again and guess what? It works! However, I really wonder why xls export function doesn't work properly. Is it about exporting entries from free version to Pro version? I hope you will solve it soon.

  4. baldure
    Member
    Posted 1 year ago #

    Hi guys.
    Thanks Matthew for a great plugin and good support.

    But I am also having problems opening a exported xls file.

    Client: iMac, OSX 10.8.2, excel 2011 v14.1
    VFB version: Pro 2.1.2

    The error I got was:
    XML ERROR in ExcelWorkbook description
    REASON: Bad Value
    FILE: wp2013feb.vfb-pro.formpro.2013-02-21.xls____________________
    GROUP: Cell
    TAG: Data
    VALUE: 2013-02-21 08:54:30

    Therer was no "T" so I added it in the exported file, and afterwards the file could be opened in excel.

    I have a client which has a very big dataset and cannot open and modify every xls file.

    Is there some news on a fix?

  5. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Are you having the same problems in 2.2? Excel can open CSV files just fine. It just doesn't have the formatting. So, give that a try.

  6. baldure
    Member
    Posted 1 year ago #

    I also have problem with 2.2, but a different error message:

    XML PARSE ERROR:  Malformed or illegal attribute name
      Error occurs at or below this element stack:
        <ss:Workbook>
         <ss:Worksheet>
          <ss:Table>
           <ss:Row>

    I can get the data out with CSV allright, but that's not the same is it?
    And in excel I can't seem to get the encoding right for the CSV file, all my special icelandic letters get messed up even if I try to open it as UTF8.

    I can however open the CVS file in Libre Office with the right encoding!

    I see the excel problem both on my Mac and on a Win7 box.

  7. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    CSV's will open just fine in Excel.

    Apparently Excel doesn't like something about certain characters even though every single value is escaped. If you want, you can send me a link to your Excel export and I'll see if I can't narrow it down for the next update.

  8. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    I actually just found a minor bug which might fix the issue.

    Can you go to the class-export.php file and go to line 577? There you will see this:
    $style = 'ss:StyleID="s62"';

    It should be this:
    $style = ' ss:StyleID="s62"';

    Replace that line and try the export again. Let me know if that solves it for you.

  9. baldure
    Member
    Posted 1 year ago #

    You're the man!
    This works for me!
    Thanks!

  10. jonwainwright
    Member
    Posted 1 year ago #

    I cant find this line at all. I have to pro version but when i export data all i get is - Entries ID - Date Submitted - IP Address - Subject -
    Sender - Name - Sender Email - Emailed To.

    Any idea how i can fix this

    BTW it was working fine until i updated my version yesterday currently using Version 2.2

  11. jonwainwright
    Member
    Posted 1 year ago #

    any ideas what could be causing this matthew?

  12. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    The Excel bug has been addressed in the latest update.

  13. jonwainwright
    Member
    Posted 1 year ago #

    Have have the updated recently 2 or 3 days ago. I didn't have a problem at all the plug worked perfectly but after the last up date when I export the entries I only get about 4 fields and it's only form info I don't get any of the data entered?? I can't export to an excel file or tabbed files or any other format???

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.