WordPress.org

Ready to get started?Download WordPress

Forums

VERY strange refresh problem (14 posts)

  1. mactac
    Member
    Posted 5 years ago #

    I'm getting a really strage issue happening.

    When firefox users (might happen with other but i'm not sure) go to my blog the first time, it forces a refresh & usually doesn't load. if you reload, or come back, it loads fine. here is the source of the page that comes up:

    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/1999/REC-html401-19991224/strict.dtd">
    <!-- <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
    "http://www.w3.org/TR/html4/strict.dtd"> -->
    <HTML>
    <HEAD>
    <META HTTP-EQUIV="Refresh" CONTENT="0.1">
    <META HTTP-EQUIV="Pragma" CONTENT="no-cache">
    <META HTTP-EQUIV="Expires" CONTENT="-1">
    <TITLE></TITLE>
    </HEAD>
    <BODY><P></BODY>
    </HTML>

    I have a number of plugins including the seo plugin and the wp-cache plugin, but I disabled them & they don't seem to be causing the problem.

    has anyone else experienced this? it's causing me major problems as you can imagine...

  2. iridiax
    Member
    Posted 5 years ago #

    Do you have an index.html or index.htm file in the same directory as WordPress? If so, delete it or rename it.

  3. mactac
    Member
    Posted 5 years ago #

    Unfortunately no, I don't

  4. iridiax
    Member
    Posted 5 years ago #

    The page code you have shown above is not WordPress code and it's not a WordPress page.

  5. mactac
    Member
    Posted 5 years ago #

    I know, but it's a wordpress site. when you go to the site, firefix tried to reload using this code for some crazy reason.

  6. iridiax
    Member
    Posted 5 years ago #

    What is your URL?

  7. mactac
    Member
    Posted 5 years ago #

    hi, the url is

    w w w . n o i s e a d d i c t s . c o m

    sorry for the spaces :)

  8. lifestyler
    Member
    Posted 5 years ago #

    its fixed? i didnt notice anything

  9. mactac
    Member
    Posted 5 years ago #

    I got exasperated with it & actually put up a new theme today hoping it would solve the problem, which it might have. I have no idea why.

    of course for some strange reason the wp-cache plugin doesn't work with this theme.... so it's a whole boatload of other problems !

  10. mactac
    Member
    Posted 5 years ago #

    DARN... it's happening with the new theme as well.

    It seems to happen the first time you go to the site (and set "warn on refresh"in firefox settings to see it clearly)

    "Firefox prevented this page from automatically reloading."

    where the heck is this coming from?

  11. MarkRH
    Member
    Posted 5 years ago #

    <META HTTP-EQUIV="Refresh" CONTENT="0.1">

    That line is what causes it to refresh in the code you posted which would cause Firefox to display that warning when that option is checked. For example, my weather page refreshes every 10 minutes with this line:

    <META http-equiv=refresh content=600>

    Firefox tosses up the same message on that page if I enable that. The content number equals the number of seconds.

  12. mactac
    Member
    Posted 5 years ago #

    yep, I know, but I can't figure out what's actually writing the refresh code....

    it's not the theme, and I don't think it's a plugin (I disabled all the ones that i suspected, like caching)

  13. mactac
    Member
    Posted 5 years ago #

    Anyone else have any great ideas?

  14. claymation
    Member
    Posted 4 years ago #

    This problem seems to be caused by Cisco's Anomaly Guard Module (AGM), which sits on the network between clients and servers and attempts to authenticate clients by challenging them with an HTML meta refresh. Contact your network provider and ask them to disable basic protection for HTTP.

Topic Closed

This topic has been closed to new replies.

About this Topic