WordPress.org

Ready to get started?Download WordPress

Forums

very slow loading write and edit admin pages (17 posts)

  1. dss
    Member
    Posted 7 years ago #

    since since the update to 2.0.4 my admin/post and admin/edit pages are loading extremely slowly.

    I've removed all the plugins, and tried reinstalling (delete, load) but nothing seems to help.

    Anyone else experiencing this? I searched (slow loading admin post edit) and found a lot of old stuff about slow pages and slow sidebars, but nothing about 2.0.4's admin posting pages. I see this on three of my installs, and a friend noticd it as well.

    Anything to be done to get the speedy backend up again?

  2. maerk
    Member
    Posted 7 years ago #

    Have you tried disabling automatic pinging of URLs you type into posts? It's in Options > Writing.

  3. dss
    Member
    Posted 7 years ago #

    yes, pingbacks and trackbacks are disabled.

  4. yosemite
    Member
    Posted 7 years ago #

    He means the services listed in "Update Services". Options:Writing.

    Delete those and test again.

  5. jprobe22
    Member
    Posted 7 years ago #

    I have the same problem. I've disabled pings and trackbacks nor do I ping any services. I've tried removing all my plugins, but that doesn't seem to have any effect. The front end of my page doesn't have any problem loading, it's just the write, edit, and manage functions of the admin area.

  6. sonofagundk
    Member
    Posted 7 years ago #

    I've tried the same - and found that optimizing the MySQL database helped a little.

    Follow the instuctions here:
    http://weblogtoolscollection.com/archives/2005/04/06/optimize-your-database/

  7. sonofagundk
    Member
    Posted 7 years ago #

    Well,
    I've been at this for several days now. As I wrote yesterday, I've optimized the MySQL database, and it helped a little. But it's still not doing the trick. The WHOLE blog is loading extremely slowly.

    I'm running WP2.0... / MySQL 3.23.55 / Mac / Safari / Firefox - but it's slow on both MS and Mac.

    Safari sometimes gives me this error:

    Safari can’t open the page “http://sonofagun.dk/blog/”. The error was: “lost network connection” (NSURLErrorDomain:-1005) Please choose Report Bug to Apple from the Safari menu, note the error number, and describe what you did before you saw this message.

    1. I've disabled both pings and trackbacks
    2. I've optimized the database
    3. I've deactivated plugins

    - So what's left to do?

  8. bgercken
    Member
    Posted 7 years ago #

    I had the same problem, with the page load taking more than a minute.
    I tracked this down to the server attempting to look up hostnames in DNS releated to content aggregation etc. My DNS settings on my server were incorrect. (I had just setup the server.) Fixing DNS solved the problem for me. Make sure that you can resolve hostnames on your server. Regards.

  9. sonofagundk
    Member
    Posted 7 years ago #

    Great. Cheers.

    How do I fix DNS? And how do I resolve hostnames?
    I'm pretty stupid when it comes to MySQL and PHP.

  10. sonofagundk
    Member
    Posted 7 years ago #

    Anyway, I checked the dns.

    This is the result:
    http://www.dnsreport.com/tools/dnsreport.ch?domain=sonofagun.dk

    My domain is located at an external host (not my own server) - can I do anything to fix the DNS-problems myself?

  11. rigosan
    Member
    Posted 7 years ago #

    Pingbacks and trackbacks are disabled...

  12. sparkletack
    Member
    Posted 7 years ago #

    I have the same problem... and it started apparently spontaneously - no changes were made to WP. (2.0.9)

    I've read every post on this subject and tried every solution, from checking DNS, killing all "ping" services, disabling plugins, disabling live preview, optimizing MySQL database...

    ...and my machine STILL locks up whenever I enter the "write" tab of the admin section for several minutes.

  13. eikman
    Member
    Posted 7 years ago #

    i have exactly the same problem. i'm not sure when it started and i did not upgrade everytime a new version came out. i am, however, pretty sure that it began with or after 2.0. i remember that i got a "500 Internal Error" occasionally while posting a new entry, so i updated to the next version of WP and it seemed to be fixed...for now. but after a while i noticed that it took longer and longer to open the "write" page and to edit entries. last summer it took 20 seconds, but these days i have to wait around 1-2 minutes, whichmakes me think that the problem is increasing while the database becomes bigger. just for the record: my DB has about 35MB and consists of roughly 700 entries, which is not *that* huge.

    at first i started to blame my host, but then i started playing around with a local webserver (xampp). i did two instllations, one on my laptop and one on my desktop pc:

    1) xampp with a new, clean WP 2.1.2. installation.
    2) xampp with WP 2.1.2. installation AND my old database.

    now guess what. the sql/apache settings are the same on both, and while the new installation works like charm, the one with my old database shows EXACTLY the same symptoms as mentioned above.

    i did a bit of research, and this is what i found out: whenever i try to open the "write new entry" page or try to edit an older entry, my HD space decreases by 300-400 MB and the CPU usage goes up by 10-15% (due to the server writing a .temp file - but why?)
    in the phpmyadmin panel, the following process appears to be the problem:

    Command: Query
    Status: Sorting for group
    SQL Query:
    SELECT meta_key
    FROM wp_postmeta
    GROUP BY meta_key
    ORDER BY meta_id DESC
    LIMIT 30

    sometimes the text edit window appears, incl. the modules on the right side, but the page still takes another 2-3 minutes to build the upload/trackback/user defined modules.

    i'm not an sql expert and i don't know how i can optimize the database, but i guess that it's the database itself that is causing the problem, since the symptoms on two different servers are the same, while a new WP installation works perfectly.

    if anyone has an idea, please let me know.

    [and yes, i tried all the mentioned fixes - plugins, pingbacks etc..]

  14. jamaal
    Member
    Posted 7 years ago #

    Hi

    I had the same problem. Deleting the services listed in "Update Services" (Options/Writing) just now worked for me.

    Thanks

  15. eikman
    Member
    Posted 7 years ago #


  16. eikman
    Member
    Posted 7 years ago #

    out of curiosity i ran a search on the process mentioned above (group by meta_key etc..).

    i found the function in the admin-functions.php and deleted the part referring to the meta fields - now guess what - write/edit pages load as fast as they are supposed to!

    however, i get an error (undefined function...) and therefore i can't edit/write entries, but it appears to be the function that is slowing down the database.

    i will take a closer look, but my PHP skills are lousy so i'm not sure exactly which part of the sourcecode to delete in order to deactivate the whole thing...

  17. eikman
    Member
    Posted 7 years ago #

    another update:

    i managed to delete the whole "custom field module" and everything seems to work now...

    what i did was deleting line 112, 269-280 and 899-1073 in admin-functions.php, as well as line 226-235 in edit-form-advanced.php (basically everything that refers to 'add_meta')

    so far i have experienced no problems...i can edit and write posts as quick as i used to...

    maybe anyone more skilled in php has an idea on how to fix the issue without deleting the meta fields, or maybe why this causing a problem (especially since i'm not even using those fields)?
    `

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags