WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Very slow loading of the images shown in gallery (5 posts)

  1. Vakantie Ameland
    Member
    Posted 10 months ago #

    Using 2.0.21 version, all other plugins deactivated.

    I still do notice that it takes a long time (>40s ) each time to load a page with a gallery. Then the photo's are loaded quickly. In 1.9.13 a page with 50 pictures in it does load rather quickly, but now it takes +/-40s to reach the page and then the photo's load quickly, another angle to look into.

    Every time a page with a gallery get's loaded it takes a long time. Per page there are 50 images. In the database I notice for all the images this query repeated:

    SELECT image_slug FROM wp_ngg_pictures WHERE image_slug = 'xxxxxxx' AND NOT pid = 0 LIMIT 1`

    This looks like the culprit of the slowdown mechanism. I'm not a mysql specialist, so someone any ideas of improving this in the nextgen code?

    http://wordpress.org/plugins/nextgen-gallery/

  2. emmalmurphy
    Member
    Posted 10 months ago #

    I have also been having major performance issues since (finally being able to) upgrading

  3. japancountdown
    Member
    Posted 10 months ago #

    Hi,

    I am also experiencing a few challenges with photo upload timeframes.

    Challenges:

    Photo Gallery page takes a considerable amount of time to open and when you click to upload a photo from the gallery it shows a black screen with a spinning white wheel which never seems to stop.

    Website gallery:
    http://www.japancountdown.com/photo-guide/

    If you could assist with some basic advice on how I can improve the page speed and upload times with Nextgen Pro that would be much appreciated.

    Kind regards,

    Daniel

  4. Vakantie Ameland
    Member
    Posted 9 months ago #

    Still this mysql query is slowing down mysql.

    SELECT image_slug FROM wp_ngg_pictures WHERE image_slug = 'xxxxxxx' AND NOT pid = 0 LIMIT 1

    Even minutes after inserting new images or viewing pages this query is being processed for every image.

    Please skip this image_slug option as this is a huge performance killer

  5. fishsponge
    Member
    Posted 7 months ago #

    has this issue been resolved in version 2.0.40?

Reply

You must log in to post.

About this Plugin

About this Topic