WordPress.org

Ready to get started?Download WordPress

Forums

Very new , need help (15 posts)

  1. lorifraize
    Member
    Posted 8 years ago #

    I have MANY questions but my first and most important is this ,
    I would like to add a few plug ins but my blog has a line that says this :
    If this file was writable you could edit it.
    How do I change that ??

  2. whooami
    Member
    Posted 8 years ago #

    to make a file writable : chmod 666

  3. lorifraize
    Member
    Posted 8 years ago #

    I wish I knew what that means or how to do it :(

  4. whooami
    Member
    Posted 8 years ago #

    chmod'ing (changing the permissions of) files can be done with most ftp clients (the application you used to upload your wp files, assuming you didnt do a fantastico install)

    I believe that the docs that come in the download explain the mimimim file/directory permissions. Following those guidelines will more than likely make that message go away.

  5. Blythe
    Member
    Posted 8 years ago #

    If you're using IE in XP, you can usually go to ftp://username:password@ftp.yoursite.com (switch out all the info for your own) and find the file that needs to be editable. Right click, go to properties, and click on the appropriate permissions checkboxes.

    This is a terrible way to go about it, but easy enough if you don't have an FTP client.

  6. T-money
    Member
    Posted 8 years ago #

    Hello? can someone help me I'm not verry good at hacker stuff, I only know the basics, and I need help burnin a dvd

  7. whooami
    Member
    Posted 8 years ago #

    youre also not good at alot of other things apparantly

  8. VaamYob
    Member
    Posted 8 years ago #

    T-money: Google is your friend.

  9. lorifraize
    Member
    Posted 8 years ago #

    ok so i found the changing stuff in my cpanel but now I am forbidden from my own blog ??

  10. whooami
    Member
    Posted 8 years ago #

    if you are getting forbidden messages than you chmod'ing the wrong thing to the wrong number. Chmod 666 is WORLD writable -- that includes you.

  11. lorifraize
    Member
    Posted 8 years ago #

    this is what i did , I went to mt cpanle I clicked www folder then wp-content folder then plug ins folder , i looked to the left and clicked change change permitions , i set them all to 666 and I get this when i try to go to my blog :

    Forbidden
    You don't have permission to access /wp-login.php on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.33 Server at http://www.mammathon.com Port 80

    SO , how do I find out what all the settings should be ? Is there a list someplace ??

  12. whooami
    Member
    Posted 8 years ago #

    go back, do exactly the same thing except chmod THAT (wp-content) to 777.

    Those are the recommended permissions for that directory. Someone can correct if I am wrong.

    To edit ANY of the files inside that directory from within the admin area of WP, you will need to change their permissions to 666.

    Rule of thumb,

    directories at @ 777: anyone can browse the dir, and ANYONE can write to the dir.

    files @ 666: anyone can view the file, and ANYONE can write to the file.

    files need never be 7** unless they need to be executable, and dirs shouldnt be 6** (under normal circumstances)

  13. petit
    Member
    Posted 8 years ago #

    I would like to add a few plug ins but my blog has a line that says this : If this file was writable you could edit it.

    I recognize the line "If this file was writable you could edit it." as the comment you get far down on the page when you go in to the Plugin/Edit Plugins page.
    Normally you don't edit the plugins and if you only wish to install some new plugins, after downloading and possibly unzipping the plugin, you copy it to its own directory under the wp-content/plugins directory.
    WordPress will automatically pick up the new plugin. It shows up in the list on the Plugins page and you may activate or deactivate it.

    You may have to leave the Plugins page( or possibly log out ) and then come back for this to happen.
    Make sure that the plugin you want to use is compatible with the version of WP you use. Not all plugins for WP 1.5.x can be used with WP 2.0.

  14. T-money
    Member
    Posted 8 years ago #

    I did google, and I got this website! go figure, I can't figure this out!

    um... help

  15. vkaryl
    Member
    Posted 8 years ago #

    T-money: your problems with burning a dvd cannot be addressed here. This is a support site specifically for wordpress forum software and installations thereof.

    If google gave you nothing usable as far as learning how to burn a dvd, then perhaps you should try either yahoo or msn. Your question is outside the purview of this forum.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.