WordPress.org

Ready to get started?Download WordPress

Forums

All In One Favicon
[resolved] Version 4.2 displays warning messages (10 posts)

  1. sdaveCL
    Member
    Posted 1 year ago #

    WordPress 3.5. Version 4.2 of plugin displays following error message. Had to revert back to 4.1.

    Warning: _() expects exactly 1 parameter, 2 given in .../public_html/wp-content/plugins/all-in-one-favicon/all-in-one-favicon.php on line 101

    Warning: _() expects exactly 1 parameter, 2 given in .../public_html/wp-content/plugins/all-in-one-favicon/all-in-one-favicon.php on line 102

    Warning: _() expects exactly 1 parameter, 2 given in .../public_html/wp-content/plugins/all-in-one-favicon/all-in-one-favicon.php on line 103

    Warning: _() expects exactly 1 parameter, 2 given in .../public_html/wp-content/plugins/all-in-one-favicon/all-in-one-favicon.php on line 104

    Warning: _() expects exactly 1 parameter, 2 given in .../public_html/wp-content/plugins/all-in-one-favicon/all-in-one-favicon.php on line 109

    Warning: _() expects exactly 1 parameter, 2 given in .../public_html/wp-content/plugins/all-in-one-favicon/all-in-one-favicon.php on line 110

    Warning: _() expects exactly 1 parameter, 2 given in .../public_html/wp-content/plugins/all-in-one-favicon/all-in-one-favicon.php on line 111

    Warning: _() expects exactly 1 parameter, 2 given in .../public_html/wp-content/plugins/all-in-one-favicon/all-in-one-favicon.php on line 112

    http://wordpress.org/extend/plugins/all-in-one-favicon/

  2. b-summers
    Member
    Posted 1 year ago #

    Having the same problems

  3. tami73
    Member
    Posted 1 year ago #

    Me too. I've reverted back to the old version.

  4. rmh625
    Member
    Posted 1 year ago #

    I have the same issue, too.

    Me too. I've reverted back to the old version.

    Tami -- or anyone -- can you explain how to do that? Thanks!

  5. b-summers
    Member
    Posted 1 year ago #

    rmh625:

    If you have a backup of your site (before you updated the plugin). Just grab the "all-in-one-favicon" folder, and drag it into your plugins folder via FTP. This will override the new version you just updated to.

    OR, sometimes the developer keeps old version on their site. You could look here:
    http://www.techotronic.de/plugins/all-in-one-favicon/

  6. sdaveCL
    Member
    Posted 1 year ago #

    Old versions of the plugin are stored in the Developers tab in the WordPress Plugins Directory:

    http://wordpress.org/extend/plugins/all-in-one-favicon/developers/

    This plugin has so few settings that I just deleted and re-installed from scratch. Keep in mind the location of the icon file.

  7. Nathaniel Bailey
    Member
    Posted 1 year ago #

    I just update my all in one fav icon plugin too and had the same warnings, but its a simple fix and just a little mistake in the coding of that file.

    Simply head to the file in the warning and change the following lines of code from:

    'frontendICO' => _('ICO',AIOFAVICON_TEXTDOMAIN),
            'frontendGIF' => _('GIF',AIOFAVICON_TEXTDOMAIN),
            'frontendPNG' => _('PNG',AIOFAVICON_TEXTDOMAIN),
            'frontendApple' => _('Apple Touch Icon',AIOFAVICON_TEXTDOMAIN)
          );
    
          //mapping of favicon types to translatable Strings
          $this->aioFaviconBackendMap = array(
            'backendICO' => _('ICO',AIOFAVICON_TEXTDOMAIN),
            'backendGIF' => _('GIF',AIOFAVICON_TEXTDOMAIN),
            'backendPNG' => _('PNG',AIOFAVICON_TEXTDOMAIN),
            'backendApple' => _('Apple Touch Icon',AIOFAVICON_TEXTDOMAIN)

    Change to:

    'frontendICO' => __('ICO',AIOFAVICON_TEXTDOMAIN),
            'frontendGIF' => __('GIF',AIOFAVICON_TEXTDOMAIN),
            'frontendPNG' => __('PNG',AIOFAVICON_TEXTDOMAIN),
            'frontendApple' => __('Apple Touch Icon',AIOFAVICON_TEXTDOMAIN)
          );
    
          //mapping of favicon types to translatable Strings
          $this->aioFaviconBackendMap = array(
            'backendICO' => __('ICO',AIOFAVICON_TEXTDOMAIN),
            'backendGIF' => __('GIF',AIOFAVICON_TEXTDOMAIN),
            'backendPNG' => __('PNG',AIOFAVICON_TEXTDOMAIN),
            'backendApple' => __('Apple Touch Icon',AIOFAVICON_TEXTDOMAIN)

    All that I have done is added an extra _ to each line (changing each _ to _e would also work, but I thought adding another _ looked easier to the eye when checking over the code in the future), which fixes the problem and will stop displaying the warnings :)

  8. techotronic
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I just released 4.2.1 where this is fixed.
    Weird, I didn't have any errormessages on my WordPress installation...

    Cheers,
    Arne

  9. sdaveCL
    Member
    Posted 1 year ago #

    Thanks Arne! No more error messages.

  10. tami73
    Member
    Posted 1 year ago #

    Yes, works great for me too. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.