WordPress.org

Ready to get started?Download WordPress

Forums

Content Aware Sidebars
[resolved] Version 2.0 overrides Primary sidebar (8 posts)

  1. cyphog
    Member
    Posted 7 months ago #

    I have one primary sidebar and two CAS sidebars: one for a specific set of posts, and one for archive pages pertaining to a specific tag.

    Upgrading to v2.0 has overriden my primary sidebar on my homepage and the only way to get the primary sidebar is to unpublish both of my CAS sidebars. Neither of those two sidebars have anything set to override the homepage and I can't figure out why it's happening.

    http://wordpress.org/plugins/content-aware-sidebars/

  2. Joachim Jensen (Intox Studio)
    Member
    Plugin Author

    Posted 7 months ago #

    Thanks for your feedback. Can you tell me your exact settings for your sidebars?

  3. cyphog
    Member
    Posted 7 months ago #

    Thanks for the prompt reply!

    Below are the settings for my two CAS sidebars. Playing around with things, it seems to be when "exposure" is set to "archive" (and I'm assuming this is also the case with "singular and archive") it overwrites the front page with whatever is in that archive CAS.

    Besides these two, the rest of my site uses the built in primary sidebar.

    CAS #1:
    Content: Posts (7 specific posts)
    Options -> Exposure: Singular
    Options -> Handle: Replace + Primary Widget Area
    Options -> Merge Position: Top

    CAS #2:
    Content: Tags (1 specific tag)
    Options -> Exposure: Archive
    Options -> Handle: Replace + Primary Widget Area
    Options -> Merge Position: Top

    Thanks!

  4. Joachim Jensen (Intox Studio)
    Member
    Plugin Author

    Posted 7 months ago #

    I can confirm this bug and I will push out a fix in a few minutes. Thank you very much for this feedback.

  5. cyphog
    Member
    Posted 7 months ago #

    Working! Thanks!

    As an aside, it looks like there's a conflict with CAS (and a number of other similar plugins) and Duplicate Widget.

  6. Tanya
    Member
    Posted 7 months ago #

    Running into the same issue with the update. Looking forward to a fix. This has been one of my most useful plugins!

  7. Joachim Jensen (Intox Studio)
    Member
    Plugin Author

    Posted 7 months ago #

    Have you updated to version 2.0.2? If so and you're still experiencing problems, please open a new thread where you give as much information about it as possible, thank you.

  8. Tanya
    Member
    Posted 7 months ago #

    Hey Joachim, I updated my settings to show singular as cyphog did. This seems to work. Thanks!

    (And yes, the problems started for me with 2.0.2. Prior to this update things were working fine!)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.