WordPress.org

Ready to get started?Download WordPress

Forums

Spam Free WordPress
[resolved] Version 1.9 DOES NOT block spam (10 posts)

  1. DZaidle
    Member
    Posted 1 year ago #

    Version 1.9 simply does not block spam.

    When I saw that an update was available, I was reticent to download it based on the broken functionality of previous "updates."

    But, I took a chance and tried it.

    And it DID NOT WORK, as I suspected.

    Within 24 hours the blog on which I installed v1.9 was getting spam comments, whereas with the old "copy and paste anti-spam password" versions the blog got zero spam.

    Needless to say, I reverted to the previous version and am staying with it on all other blogs that I administer.

    NOTE TO USERS: DO NOT UPDATE IF YOUR CURRENT VERSION IS WORKING.

    I do not know what the author is trying to accomplish, but it isn't working.

    The older versions worked just fine. If it ain't broke, don't try to fix it.

    http://wordpress.org/extend/plugins/spam-free-wordpress/

  2. Todd Lahman
    Member
    Plugin Author

    Posted 1 year ago #

    1.9 offers both the old and a new spam blocking method as separate options, so claiming this new version doesn't work, and at the same time claiming the old version still does, is a contradiction. This might be news to you, but sometimes plugins require you to choose a few configuration options to make it work for your blog environment.

    If you had taken the time to ask for support on the official forum, your issue could have been resolved by checking a couple of options.

    I suggest you read this http://www.toddlahman.com/spam-free-wordpress/#troubleshooting if you want to give 1.9 another try, or ask me for help on the official support forum. The plugin works, you just need a little help.

  3. carolm
    Member
    Posted 1 year ago #

    Hi Todd, you say that 1.9 still offers the copy/paste method of blocking spam but I can't find it anywhere in Settings, or anywhere else. Since I updated to 1.9 there is no copy/paste hurdle to get over, and I can even post a test Comment without even submitting an email address, just a first name is enough.

    I checked out your link above to Troubleshooting, but couldn't see how to get the copy/psste option back there either.

    The site is http://www.MySecondMillion.com

    Some help would be great. Thanks.

  4. webvitaly
    Member
    Posted 1 year ago #

    Try to use Anti-spam plugin. It blocks spam automatically and without captcha.

  5. Todd Lahman
    Member
    Plugin Author

    Posted 1 year ago #

    Hi carolm,

    Both the old non-JavaScript, and the new JavaScript methods of blocking spam built into the plugin work in the background, so there is no longer a password field that shows up on the comment form. I checked your blog, and it is using the more secure JavaScript method of blocking spam.

    For future support requests please obtain your free license key, login, and use the support forums at: http://www.toddlahman.com/forums/forum/spam-free-wordpress/

  6. carolm
    Member
    Posted 1 year ago #

    Thanks for checking it out, Todd. I must admit, that even though you say it is working in the background, I feel safer if i can see the copy/paste option when I write a test Comment. But, if you say it is working ok, then I will trust you.

    I did go to your Support Forum - the text there was so pale, plus the Private Forum Title at the top, it made me think I didn't have access there, even though I was logged in.

    In fact, I now see that I did have access there, after all, and access was not 'greyed out'. So sorry I didn't post my question over there.

    Thanks again.

  7. balinor
    Member
    Posted 1 year ago #

    Unfortunately I have to agree with DZaidle, upon upgrading this morning I was immediately flooded with SPAM comments. Tried all of the settings, so that wasn't the issue. Tried it on a couple of different servers just to make sure it wasn't a setting there causing it. When I reverted back to the previous version, the SPAM was once again blocked. Not sure why the change was made, but the cut/paste method seems to be the only 100% guaranteed way to keep them out. Great mod, couldn't live without it, but need to be very careful when messing with a great thing!

  8. DZaidle
    Member
    Posted 1 year ago #

    I do not understand how this can be marked "resolved" when it clearly hasn't.

  9. carolm
    Member
    Posted 1 year ago #

    I thought I had posted a comment here a couple of hours ago but it's not here now....so I'll say it again.

    This upgraded version of the Plugin DOES work. I've been checking my Spam Free Stats and this plugin is still blocking the Evil Spam Doers at the front door. The numbers blocked are still going up, and I have not been hit with a flood of Spam Comments either.

    That is my experience anyway. I wrote a couple of articles about how I set up my Comments Settings and Plugin Settings to encourage Comments but block spammers here:

    http://www.mysecondmillion.com/customize-wordpress-comments/

    Thanks Todd.

  10. directdepot
    Member
    Posted 1 year ago #

    Todd, the update is Nt working for me either. The site is:

    http://www.lisalisad1.com/

    If you see anthing thing wrong with the site please let me know. Is the prior version of the plug-in available. I never had a problem with it.

    Thanks...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic