WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
version 0.9.7.1 create a permanent redirect loop (7 posts)

  1. pupunzi
    Member
    Posted 1 year ago #

    Hi,
    I'm having problems after installing the latest 0.9.7.1 version; the site can't load and from the net console it seams there's a unresolved redirect loop that ends with "Too many redirect recursions" error. This happens cross browsers (FF, Safari, Chrome, Opera) tested on a local MAMP web-server on a Mac OsX Mountain Lion. At the time I rolled back to the 0.9.6 that works fine, so there's no links to let you see the problem.

    My Polylang settings:

        [checked] set the language according to the browser preference
        [checked] The language code is added to all urls when using pretty permalinks.
        [checked] Remove /language/ in pretty permalinks.
        [checked] Allow to synchronize categories, tags, featured image and other metas between translations of a post or page

    Permalinks: Day and name

    Bye,
    Matteo

    http://wordpress.org/extend/plugins/polylang/

  2. pupunzi
    Member
    Posted 1 year ago #

    Just updated to version 0.9.8; the bug persists but checking

    When using static front page, redirect the language page to the front page in the right language

    Seams to solve the problem.
    Anyway, if that is not checked the recursion problem exists.

    Bye,
    Matteo

  3. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Did you check for any plugin or theme conflict?

  4. pupunzi
    Member
    Posted 1 year ago #

    Deactivated all the other plug-ins, changed theme (I'm using a cusotmized Twenty twelve), cleared cache and cookies but the bug persists.
    Doesn't seams a plug-in conflict problem. Maybe is how Polylang 0.9.8 manage previously inserted content... probably a DB problem.

    ... 10 minutes later ...

    I start up with a clean installation adding only polylang, with the default WP theme; I add 2 languages (eng, it) added 2 static page (one for each languages), activated "day and name" permalinks and the bug came out:

    If
    "Hide URL language information for default language" is NOT checked
    and
    "When using static front page, redirect the language page to the front page in the right language" is NOT checked

    calling the root goes to an infinite redirect loop.

    Hope this help for the debug.
    Bye,
    Matteo

  5. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I don't understand why it doesn't work in your installation, as I don't succeed to reproduce the bug. However I made a modification in the development version which may solve the issue. Could you try it (0.9.8.1)?
    http://downloads.wordpress.org/plugin/polylang.zip

  6. pupunzi
    Member
    Posted 1 year ago #

    Hi,
    Whatever you changed solved the issue.

    Couldn't it depend from the MAMP web server I'm using?
    Bye,
    Matteo

  7. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    To better explain what happened.

    When you are using a static front page, WordPress redirects http://yoursite.com/front-page to http://yoursite.com. That's fine on a monolingual site.

    Now with Polylang, you have several front pages that you must differentiate. And when you choose your options http://yoursite.com should be redirected to http://yoursite.com/front-page-in-this-language. But WordPress will want to come back to yoursite.com and I must block this.

    So after the first redirection done by Polylang, I compared the requested url (which is already the result of the first redirection) to the url of the front page in the right language. For some reason, this direct comparison does not return true in your case and so WordPress redirection is not blocked and you enter the infinite loop.

    Hopefully, I found a more robust way to stop the second redirection.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic