WordPress.org

Ready to get started?Download WordPress

Forums

Ver. 2.2 Kills Widgets (8 posts)

  1. suspensewriter
    Member
    Posted 7 years ago #

    Thought I’d go ahead and update WordPress to the newest version (Ver. 2.2, got the following message:
    Fatal error: Cannot redeclare register_sidebars() (previously declared in /path/to/writingdiary2/wp-includes/widgets.php:15) in /path/to/writingdiary2/wp-content/plugins/widgets.php on line 22

    This is an across-the-board error–doesn’t matter what template I use. I have no clue how to fix this, and I can’t make any changes in the sidebars until it’s fixed. Anyone else updated to WordPress 2.2 and found (and fixed) the same error?

  2. Chris_K
    Member
    Posted 7 years ago #

    Did you disable all plugins before the upgrade?

    Do you have a widgets plugin still enabled from previous versions? If so, have you tried disabling it (isn't that built-in to 2.2 now?)?

  3. neville
    Member
    Posted 7 years ago #

    I just upgraded one of my blogs from 2.1 to 2.2. This is a sandbox blog with no plugins at the moment other than those that come with WP.

    Checked the plugins list, saw Sidebar Widgets version 1.2.1.20070210b. Not activated so clicked on activate.

    Result was this text at top of screen -

    Plugin could not be activated because it triggered a fatal error

    No idea what the fatal error is/was.

    Blog functions ok but without widgets at the moment.

  4. suspensewriter
    Member
    Posted 7 years ago #

    I had all widgets and plugins disabled. There's no way to get into widgets to do anything, because that's where the error message is.

    Screenshot

  5. neville
    Member
    Posted 7 years ago #

    Figured out what the problem was in my case. Nothing to do with 2.2 or in-built widgets. I think.

    I had the separate widgets plug-in installed for version 2.1. When I upgraded to 2.2, that plugin was still there, albeit not activated. The fact that it's there must do something, somewhere, as I could not get widgets working at all.

    I've now deleted the widgets folder and all files from the plugins directory - and widgets now work.

  6. suspensewriter
    Member
    Posted 7 years ago #

    Thanks, Neville, that worked for me, too. Didn't have to delete anything but the widget plug-in. Everything else worked immediately. Now I just have to get the widgets to work the way I want them to, and figure out how to get non-widget items into the sidebars.

  7. milprod
    Member
    Posted 7 years ago #

    Have the same problem. (Fatal Error). Ran instant upgrade with all plugins deactivated.
    Deleted the widgets folder from the plugins directory, but none of the widgets (that are still there), show on the blog.
    I just can't figure out how to get my site back to how it looked before the upgrade.
    I can rearrange the widgets in the admin menu (presentation/widgets), but it has no effect on the site.
    Grateful for any suggestions.

  8. Lynn
    Member
    Posted 7 years ago #

    I tried removing widgets.php from the plugins folder and still have no Widgets Subpanel (tab) in the Presentation menu. (Also deleting the whole widgets folder did no good.)

    I'm using WP 2.2 and the Half-Life theme (but I know this has nothing to do with this fine widget-ready theme).

    I don't think this widgets-in-the-core idea is very good at all.

    Oddly, the widgets I set up BEFORE the upgrade to 2.2 are still showing up in the sidebar, but there is no way to edit them.

    Ideas welcome: how to edit the old widgets? how to get around the widgets-in-the-core craziness? how to get the Widgets tab back into Presentation?

Topic Closed

This topic has been closed to new replies.

About this Topic