WordPress.org

Ready to get started?Download WordPress

Forums

Google Forms
ver 0.44 setting page doesn't show up (11 posts)

  1. matteoromagnoli
    Member
    Posted 1 year ago #

    Hi,
    I uploaded the plugin to version 0.44, but I can't see the setting page. It loads for a while and the nothing, blank page.
    As far as I can debug "options-general.php" fails to load. Can't see any relevant error on Apache's Error Log.

    Hope it can be solved, I really need and like this plugin.
    Thanks

    http://wordpress.org/extend/plugins/wpgform/

  2. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    Do you know what version of PHP you are running? Does your form still work even without the settings page working? Do you know if you had debug enabled or disabled?

  3. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    The settings page loads a jQuery UI modules from Google's CDN as well as the content for the Usage, FAQ, and About tabs from the WordPress Plugin Repository. It is possible that the HTTP API could time out trying to load the content from the Plugin Repository although a refresh would almost certainly fix it.

    I am running WordPress 3.4.2 with my site and cannot replicate this behavior. Have you changed anything else? Which browser are you using? If you're using Firefox, can you check the Web Developer->Tools->Error Log and see if you see any Javascript errors?

  4. matteoromagnoli
    Member
    Posted 1 year ago #

    • PHP version: 5.3.6
    • Yes, actually the form works, sorry for the pressure :)
    • What do you mean debug enable? If is it possible to enable debug mode on the plugin I didn't

    I checked with Chrome Development Tools: the only error is:
    Failed to load resource http://127.0.0.1:8888/wordpress/wp-admin/options-general.php?page=wpgform-options.php

    Looking at headers everything seems to be fine, but the response content is not complete: it stops at this line of the file <li id="wp-admin-bar-edit-profile" class=""><a class="ab-item" tabindex="10" href="http://127.0.0.1:8888/wordpress/wp-admin/profile.ph"<a> even without closing the element.

    Yeah, it looks to me as well that it could be a timeout issue. Maybe it is due to the fact that I'm working on a local webserver?

    Hope can help!

  5. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    Since you're running locally, do you have WordPress Debug enabled? This might give us some insight as to why the page isn't loading. If you have FireFox available, you may want to load FireBug and check the Network tab, it can show which request is taking so long.

    I was trying to think of a way to turn off loading the tab content I load from the WordPress Plugin Repository and the only way which would work would be using a define much like WordPress Debug does. I'd be happy to throw together a debug release for you to try if you want me to. LMK.

  6. matteoromagnoli
    Member
    Posted 1 year ago #

    No, I was not in Debug. Here what I get enabling debug mode:
    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in C:\Program Files (x86)\EasyPHP-5.3.6.0\www\wordpress\wp-includes\functions.php on line 2758

    This is what I get from firefox (descriptions are in italian, sorry):

    `
    [15:33:08.583] GET http://127.0.0.1:8888/wordpress/wp-admin/options-general.php?page=wpgform-options.php [HTTP/1.1 200 OK 9154ms]
    [15:33:12.550] GET http://127.0.0.1:8888/wordpress/wp-admin/css/colors-fresh.css?ver=3.4.2 [HTTP/1.1 304 Not Modified 2ms]
    [15:33:12.551] GET http://127.0.0.1:8888/wordpress/wp-content/plugins/vertical-news-scroller/js/jquery.validate.js?ver=3.4.2 [HTTP/1.1 304 Not Modified 4ms]
    [15:33:12.430] Errore durante l'interpretazione di 'background-image'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:1
    [15:33:12.430] Previsto un colore, invece è stato rilevato 'bottom'. Errore durante l'interpretazione di 'background-image'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:1
    [15:33:12.430] Proprietà sconosciuta '-moz-box-shadow'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:1
    [15:33:12.431] Proprietà sconosciuta 'box-sizing'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:1
    [15:33:12.431] Pseudo-classe o pseudo-elemento sconosciuto '-webkit-input-placeholder'. Insieme di regole ignorato a causa del selettore errato. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:1
    [15:33:12.431] Previsto un media feature name, trovato '-webkit-min-device-pixel-ratio'. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:1
    [15:33:12.431] Pseudo-classe o pseudo-elemento sconosciuto '-webkit-search-decoration'. Insieme di regole ignorato a causa del selettore errato. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:2
    [15:33:12.432] Errore durante l'interpretazione di 'white-space'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:2
    [15:33:12.432] Proprietà sconosciuta 'user-select'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:2
    [15:33:12.433] Errore durante l'interpretazione di 'filter'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:2
    [15:33:12.435] Errore durante l'interpretazione di 'vertical-align'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:2
    [15:33:12.438] Errore durante l'interpretazione di 'text-shadow'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2:2
    [15:33:12.441] Proprietà sconosciuta 'zoom'. Dichiarazione tralasciata. @ http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/themes/base/jquery-ui.css?ver=3.4.2:13
    [15:33:12.441] Errore durante l'interpretazione di 'filter'. Dichiarazione tralasciata. @ http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/themes/base/jquery-ui.css?ver=3.4.2:14
    [15:33:12.442] Proprietà sconosciuta '-moz-border-radius-topleft'. Dichiarazione tralasciata. @ http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/themes/base/jquery-ui.css?ver=3.4.2:457
    [15:33:12.443] Proprietà sconosciuta '-moz-border-radius-topright'. Dichiarazione tralasciata. @ http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/themes/base/jquery-ui.css?ver=3.4.2:458
    [15:33:12.443] Proprietà sconosciuta '-moz-border-radius-bottomleft'. Dichiarazione tralasciata. @ http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/themes/base/jquery-ui.css?ver=3.4.2:459
    [15:33:12.443] Proprietà sconosciuta '-moz-border-radius-bottomright'. Dichiarazione tralasciata. @ http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/themes/base/jquery-ui.css?ver=3.4.2:460
    [15:33:12.443] Proprietà sconosciuta '-moz-border-radius'. Dichiarazione tralasciata. @ http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/themes/base/jquery-ui.css?ver=3.4.2:464
    [15:33:12.488] Errore durante l'interpretazione di 'background-image'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/css/colors-fresh.css?ver=3.4.2:1
    [15:33:12.488] Previsto un colore, invece è stato rilevato 'top'. Errore durante l'interpretazione di 'background-image'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/css/colors-fresh.css?ver=3.4.2:1
    [15:33:12.488] Proprietà sconosciuta '-moz-box-shadow'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/css/colors-fresh.css?ver=3.4.2:1
    [15:33:12.489] Previsto un colore, invece è stato rilevato 'bottom'. Errore durante l'interpretazione di 'background-image'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/css/colors-fresh.css?ver=3.4.2:1
    [15:33:12.490] Previsto un colore, invece è stato rilevato 'right'. Errore durante l'interpretazione di 'background-image'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/css/colors-fresh.css?ver=3.4.2:1
    [15:33:12.490] Previsto un media feature name, trovato '-webkit-min-device-pixel-ratio'. @ http://127.0.0.1:8888/wordpress/wp-admin/css/colors-fresh.css?ver=3.4.2:1
    [15:33:12.491] Errore durante l'interpretazione di 'filter'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/css/colors-fresh.css?ver=3.4.2:1
    [15:33:12.491] Errore durante l'interpretazione di 'text-shadow'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/css/colors-fresh.css?ver=3.4.2:1
    [15:33:12.491] Previsto un colore, invece è stato rilevato 'none'. Errore durante l'interpretazione di 'border-right-color'. Dichiarazione tralasciata. @ http://127.0.0.1:8888/wordpress/wp-admin/css/colors-fresh.css?ver=3.4.2:1`

  7. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    I don't think the enqueue_script error/warning is from my plugin as I don't see it in my log when I have DEBUG on. Looking through the code, everything is hooked into the proper actions to the best of my knowledge.

    Can you try changing your theme to Twenty-Ten or Twenty-Eleven and see if the problem persists? If it does, disable all plugins except WordPress Google Form and see if it still happens. If it doesn't, try enabling the plugins one by one until it happens again. This strikes me as a plugin conflict of some sort.

  8. matteoromagnoli
    Member
    Posted 1 year ago #

    Ok, I will.
    I'm working on Twenty-Eleven them so I go directly on the plugin test.
    I noticed that also the inline validation is not working. Unfourtunatly I can't test the website online yet, but I suspect jQuery is not working on my local server. Could be possible?
    Moreover, I should validate an email field. Where I can put my hands in order to add the feature?
    Thanks, let you know about plugin asap.

  9. matteoromagnoli
    Member
    Posted 1 year ago #

    I disabled all plugins, but it still not working. This time it loads the title and the "Please Donate..." text.
    But the the request fails and I don't get the rest of the page.

    I suggest to postpone further checks once I could be online. LYK.

  10. matteoromagnoli
    Member
    Posted 1 year ago #

    Please don't consider the previous comment on jQuery inline validation failing: my fault!! :)

  11. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    When working offline jQuery should still be loaded with WordPress however the jQuery UI Tabs module requires CSS to work properly. Unfortunately that CSS module is not (to the best of my knowledge) included with WordPress so I load it from Google's CDN. If WordPress can't get to the Google CDN then the page will still work, you'll just see a series of links near the top of the page for each of the tabs instead of the nice tabbed interface. Everything still works though, it just doesn't look as elegant.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.