WordPress.org

Ready to get started?Download WordPress

Forums

WP Vegas
[resolved] Vegas Slider not working on site (8 posts)

  1. sarahwnyc
    Member
    Posted 11 months ago #

    Hi, I can't seem to get the plugin to work on my site. I've tried do_shortcode(); in the header.php file, I've tried putting the shortcode in the content area of my static home page, and I've tried <?php wp_enqueue_script('jquery'); ?> before wp_head();, and I'm only able to load a blank background instead of the graphic I have saved.

    You can see the site here.

    http://wordpress.org/plugins/vegas-fullscreen-background-slider/

  2. jamesdbruner
    Member
    Plugin Author

    Posted 11 months ago #

    Okay so you're loading the vegas function twice which is atleast part of the problem. Check on the vegas settings page and see if the global option is on and try turning that off. If it's still blank I would ask if you have do_shortcode in the header AND if you're using the shortcode in the page too. I hope that makes sense and hopefully that'll help! Let me know how that goes.

  3. sarahwnyc
    Member
    Posted 11 months ago #

    Thanks for having a look. I commented out the do_shortcode in the header and left the shortcode in the page content for my homepage, and it's still not working even after trying to turn off the global option. I tried removing the shortcode in the page content and uncommenting the do_shortcode in the header, and no luck.

    I checked the code being generated, and it is firing the jQuery, it's just not displaying the photo.

  4. jamesdbruner
    Member
    Plugin Author

    Posted 11 months ago #

    So from what I can tell, right now...
    This is up in the header

    <script>
    jQuery( function() {
      jQuery.vegas('slideshow', {
      delay:1000,
      backgrounds:[
    { src:'http://dave.capiscounited.com/wp-content/uploads/2013/08/falcon-web3.jpg', fade:1000 },  ]
    })('overlay', {
       src:''
    })
    });
    </script>

    and then this is called down farther in the body.

    <script>
    jQuery( function() {
      jQuery.vegas('slideshow', {
      delay:1,
      backgrounds:[
    { src:'http://dave.capiscounited.com/wp-content/uploads/2013/08/falcon-web.jpg', fade:1 },{ src:'http://dave.capiscounited.com/wp-content/uploads/2013/08/falcon-web1.jpg', fade:1 },{ src:'http://dave.capiscounited.com/wp-content/uploads/2013/08/falcon-web2.jpg', fade:1 },  ]
    })('overlay', {
       src:''
    })
    });
    </script>

    Also another issue is that vegas.js isn't being enqueued at all. If you want I can take a closer look if you don't mind emailing me a username and password that has admin privileges. My email address is jamesdbruner@gmail.com

  5. sarahwnyc
    Member
    Posted 11 months ago #

    Thanks James, I just emailed you the info.

  6. jamesdbruner
    Member
    Plugin Author

    Posted 11 months ago #

    I'm marking this as resolved since it's a theme related issue and not an issue with the plugin itself.

  7. sarahwnyc
    Member
    Posted 11 months ago #

    Thanks for your help, James!

  8. jamesdbruner
    Member
    Plugin Author

    Posted 11 months ago #

    You're welcome! I'm sorry I couldn't fix the issue for you! :(

Reply

You must log in to post.

About this Plugin

About this Topic