WordPress.org

Ready to get started?Download WordPress

Forums

WP Vegas
[resolved] Vegas Slider Not Autoplaying (6 posts)

  1. Matt Gross
    Member
    Posted 11 months ago #

    So I installed the Vegas Slider plugin yesterday, and I'm pretty impressed so far, but for whatever reason, I can't get it to display multiple slides. I've got several in the queue, but it displays the first slide and nothing more. Could it be that my slides have different resolutions?

    link to site: http://testing.mattgrossdesign.com/wordpress/

    Thanks,

    Matt

    http://wordpress.org/plugins/vegas-fullscreen-background-slider/

  2. jamesdbruner
    Member
    Plugin Author

    Posted 11 months ago #

    What happens if you move a different image to the top left (making it the first image in the set) does it just display that one? Also are you using the shortcode or are you using the global option or both? If you're doing both that can cause issues.

  3. jamesdbruner
    Member
    Plugin Author

    Posted 11 months ago #

    Ok, I looked at your source code and here's what I noticed...

    There's this script

    <nav id="nav-arrows" class="nav-arrows"><span id="nav-arrow-prev">Previous</span><span id="nav-arrow-next">Next</span></nav><script>jQuery( '#nav-arrow-prev' ).click( function() { jQuery.vegas('previous'); });jQuery( '#nav-arrow-next' ).click( function() { jQuery.vegas('next'); });</script><script>
    jQuery( function() {
      jQuery.vegas('slideshow', {
      delay:500,
      backgrounds:[
    { src:'http://testing.mattgrossdesign.com/wordpress/wp-content/uploads/2013/08/biomedical-front-page.jpg', fade:500 },{ src:'http://testing.mattgrossdesign.com/wordpress/wp-content/uploads/2013/08/Organs-White.jpg', fade:500 },{ src:'http://testing.mattgrossdesign.com/wordpress/wp-content/uploads/2013/08/scotiaband-front-page.jpg', fade:500 },{ src:'http://testing.mattgrossdesign.com/wordpress/wp-content/uploads/2013/08/windmill-front-page.jpg', fade:500 },{ src:'http://testing.mattgrossdesign.com/wordpress/wp-content/uploads/2013/08/Zagato.jpg', fade:500 },  ]
    })('overlay', {
       src:''
    })
    });
    </script>

    Which is awesome. That's how it should be, but farther down near your footer there's this

    <script>
    jQuery( function() {
      jQuery.vegas('slideshow', {
      delay:500,
      backgrounds:[
    { src:'', fade:500 },  ]
    })('overlay', {
       src:''
    })
    });
    </script>

    Now I'm not sure why that's there but I'm almost 100% positive that's what's causing your issue. Let me know if you need further assistance!

  4. Matt Gross
    Member
    Posted 10 months ago #

    Thanks James! I'll have a look at that as soon as I get back to my computer, I've no idea how that second chuck of script got there.

    I'll let you know what happens.

    Matt

  5. Matt Gross
    Member
    Posted 10 months ago #

    Okay, figured it out. The second script was being generated by the global option, while I had the shortcode embedded into the header.php file. I was wondering why the slideshow options weren't having any effect, now we know.

    Thanks James!

    Matt

  6. jamesdbruner
    Member
    Plugin Author

    Posted 10 months ago #

    I'm glad you got it working! Have a good one Matt!

Reply

You must log in to post.

About this Plugin

About this Topic