WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] vCita activated on update to 4.0.14? (17 posts)

  1. allm
    Member
    Posted 9 months ago #

    After an update to 4.0.14 suddenly vCita was enabled on the form. I am 99,999% sure that was not active in the previous version of the plugin.

    Is this a bug?
    Did vCita receive any information about the website?

    http://wordpress.org/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 9 months ago #

    There was a coding error on 4.0.13 that caused some buttons to be accidentally enabled, but nothing was sent to vCita because the service was not activated. You still have to enter your first name, last name, and email and click Save changes to activate.

    But not in 4.0.14, vCita schedule a meeting button cannot enable itself.

    How to disable the “Schedule an Appointment” vCita button
    http://www.fastsecurecontactform.com/how-to-disable-vcita

  3. allm
    Member
    Posted 9 months ago #

    Hi Mike,

    Thanks for your quick reply. If I remember correctly I updated from 4.0.12 to 4.0.14. So 4.0.13 never made it to the website.

    To be absolutely sure I updated another site from 4.0.6 to 4.0.14 and on that site vCita got enabled as well.

    I guess the bug is still in 4.0.14...

  4. Mike Challis
    Member
    Plugin Author

    Posted 9 months ago #

    I suspect 4.0.12 or one of the earlier 4.xx versions might have done that.

    There is nothing wrong with 4.0.14, it has been, fixed, checked, and double checked.

    If you had a button enabled, you have to disable it on the Scheduling tab. I cannot make 4.0.14 just disable for you because some people do want it enabled you see.

    Sorry for any inconvenience

    Mike

  5. allm
    Member
    Posted 9 months ago #

    OK, I'll check another site. I'll report back shortly.

    In the website that was at 4.0.6 there was no vCita visible undere the form, but I did not check the settings in the admin area. After update to 4.0.14 the vCita thing was under the form and the setting was checked.

    I understand that you cannot make a fix just for me, but on my end it looks like the 4.0.14 still has the bug, not just for me. I'll report back in a few minutes...

  6. allm
    Member
    Posted 9 months ago #

    I just checked another site.
    It was at 4.0.13, no vCita thing under the form, vCita scheduling not checked. Apparently the update to .13 went OK.
    The update to .14 also went fine.

    And another site:
    It is now at 4.0.6. There is no vCita thing under the form. In the admin area "Enable Online Scheduling with vCita" is off, but "Add a scheduling button to your form" is on. That explains why I don't see anything under the form, but I have never wanted the "Add a scheduling button to your form" to be on, and have never taken any action to do so.
    After updating to 4.0.14 there is no check possible for "Enable Online Scheduling with vCita", and now the setting seems to be on, as there is a vCita thing under the form.

    I guess somewhere during updates in the 4.0.x range this gets introduced, and I suspect not to be the online one.

    A further guess is that it is a good idea to check all forms for active vCita code after updating.

    I am not trying to be a pain, but I am trying to help you make a plugin that is already very good even better.

  7. allm
    Member
    Posted 9 months ago #

    By the way: it is easy to correct on my part. I can just uncheck "Add a scheduling button to your form" under the scheduling options...

    It's just a thing that might probably bug some other people as well, and maybe they don't notice, because you don't check your forms after every update. And there are a lot of updates lately, which is a good thing and much appreciated!

  8. mbrsolution
    Member
    Posted 9 months ago #

    Hi @Mike, thank you for such a superb plugin. Your new version is awesome.

    I can confirm that upgrading from 4.0.13 to 4.0.14 did enable the vCita form on all my websites.

    Kind regards

  9. Mike Challis
    Member
    Plugin Author

    Posted 9 months ago #

    Yes I appreciate all the help and feedback, I cannot understand how it could enable itself in 4.0.14. If it became enabled it was probably a prior 4.xx version that did that.

    This is open source software and anybody can see the code and the changes I have made to it.

    Here is the global changes from 10-9-2013 that disable the default settings for all vCita options, they are still disabled and will remain so.
    http://plugins.trac.wordpress.org/changeset/785583/si-contact-form

    Again, if the button somehow became enabled and you want it disabled, you have to disable it on the Scheduling tab. I cannot make 4.0.14 just disable it automatically because some people do want it enabled.

    Sorry for any inconvenience

  10. mbrsolution
    Member
    Posted 9 months ago #

    Hi @Mike, yes I understand what you mean.

    Perhaps if you cannot make any changes you might want to add some information on the FAQ or the Description page to let users know that this feature might become enabled when upgrading to the latest version and how to disable this option if they don't require it.

    Kind regards

  11. allm
    Member
    Posted 9 months ago #

    Hi Mike,

    I understand why it is difficult to see what is going on. Maybe my description (see above) of the website that went from 4.0.6. to 4.0.14 explains what is going on.

    I am really sure that I did not activate/try or whatever else with vCita pre-4.xx.

    Somehow the "Add a scheduling button to your form" gets activated with 4.0.6 or before. It does not result in any action then, because "Enable Online Scheduling with vCita" is still off. But the update to 4.0.14 translates this to activating vCita.

    I will check with sites that are still 3.xx, and report anything that seems interesting to this issue.

    If there is something you want me to look at, please add it to this thread and I will check that.

    mbrsolution's remark seems a good idea. We're probably not the only ones...

    Of course I know it is easy to fix this on my part: just check all forms on update. I just hope that this is a rare issue, and mbrsolution and I are the exceptions...

  12. Mike Challis
    Member
    Plugin Author

    Posted 9 months ago #

    OK I looked at other parts of the code where it displays the button and I see where I can make some improvements. Thanks for the help everybody.

  13. allm
    Member
    Posted 9 months ago #

    Thanks Mike! I'll set this to resolved. I'll check the next few updates and report if anything comes up again.

    Have a good weekend!

  14. Mike Challis
    Member
    Plugin Author

    Posted 9 months ago #

    Should be fixed now for sure, and for those who had it accidentally show up
    http://plugins.trac.wordpress.org/changeset/786784/si-contact-form

  15. slreagan
    Member
    Posted 9 months ago #

    I submitted a support ticket on this but in case it is easier to reply here... Am having the opposite problem - I cannot get vCita button to work. Have a vCita account already and am up to date on both WP & FSCF; have all the appropriate boxes checked, email is correct, basically everything in the form works EXCEPT the vCita Scheduler part.

  16. Mike Challis
    Member
    Plugin Author

    Posted 9 months ago #

    I helped @slreagan by email, problem solved with 2 line code fix.

    I just released Version 4.0.15

    This version solves all known issues with vcita

    For those who had the schedule a meeting button show when not activated, sorry for any inconvenience, this is fixed, it will not do that anymore. Even if you click the checkbox to show the button on your form, it will not show it unless you also fill out your email, first name, last name, and click save changes.

  17. slreagan
    Member
    Posted 9 months ago #

    And it works perfectly! Thank you Mike for all your help!

Reply

You must log in to post.

About this Plugin

About this Topic