WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Variations not working (16 posts)

  1. AnnieInItaly
    Member
    Posted 1 year ago #

    I have created variations on my products before without issue, but for some reason this option has stopped working. I created my attributes (4 different ones), I clicked save, and went to the variations tab. When I click on 'add variations', nothing happens. If I remember correctly, a box should drop down that allows me to actually create them and put in the necessary info. I click on it, and zilch happens.

    What do I do to make this start working again? Could it be that I'm running wordpress in another language, through Localization (I think that is what it is called in English)?

    http://wordpress.org/extend/plugins/woocommerce/

  2. Coen Jacobs
    Member
    Plugin Author

    Posted 1 year ago #

    Have you marked the attributes to be used with variations (with this checkbox)?

  3. AnnieInItaly
    Member
    Posted 1 year ago #

    yes, I checked the box (and unchecked the other) in attributes before saving.

  4. jamietelin
    Member
    Posted 1 year ago #

    It seems like it's a bug since I updated to 2.0.5.

    I can add a new variation product, publish it. But when i try and edit it it has lost the settings on "use for variation"-checkbox in attributes. I must then check the "use for variation"-checkbox under attributes again. Then reselect my attributes variations for my variations and click update.

    To replicate problem:

    • Add new product.
    • Select the product to be "Variation product".
    • Fill out the normal stuff.
    • Add some attributes to be used, check "use for variation".
    • Click save attributes
    • Now you can click variations and change add variations based on the attributes.
    • Then you publish the product
    • But then, you open the product for editing again, and the checkbox under attributes; "use variation", is no longer checked. And my variations have lost their attributes, still there but with no dropdowns.
  5. sleepymonk
    Member
    Posted 1 year ago #

    Ok, just tested this and it works. You need to save at every stage, rather than trying to enter everything at once.

    First you need to set up attributes in the PRODUCT menu. For example, SHOE COLOR.
    Then you CONFIGURE TERMS for this attribute (click on the button at the right hand side beside SHOE COLOR).
    Add colors individually, such as black, brown, plaid, etc.

    Then go to your product page. Beside Product Data select VARIABLE (rather than SIMPLE PRODUCT). SAVE (update).
    Click on ATTRIBUTES and add the attribute you created earlier (SHOE COLOR). SAVE (update).
    Click on VARIATIONS and individually add each shoe color, ie BLACK (remember to SAVE, update after each one).

    View your page and you'll see colours listed on the ADDITIONAL INFORMATION tab.
    You'll also see a drop-down menu on the product page where you can select the colour. Add it to the cart and you'll see the colour selection there.

    WooCommerce will remind you that you need to add attributes first before adding them to the product page.

    Hope that helps!

  6. AnnieInItaly
    Member
    Posted 1 year ago #

    Thanks for the response.

    I tried that, and with saving at absolutely every step I now see the product variation box on my page. HOWEVER, the variations aren't visible! In the little box it just says, 'choose an option' (translated from Italian), but it doesn't have any of my variations in the dropdown even though I'm pretty sure I did everything right (they show up in the attributes tab and variations tab).

    Is this some crazy bug in WP or am I doing something wrong?

  7. sleepymonk
    Member
    Posted 1 year ago #

    If you go to PRODUCTS, ATTRIBUTES, is the TYPE "select" or "text"?

    SELECT is select from drop-down menu
    TEXT is type in the selection

  8. sleepymonk
    Member
    Posted 1 year ago #

    If you've done that, next steps to check would be (I am checking on my website, which is not online yet, but is working ok):

    1. Go to the product
    2. Check that product type is set to VARIABLE (not simple product)
    3. Check that attributes are set up for this product (ATTRIBUTES MENU within product), check that "used for variations" is checkmarked
    4. Did you add values with this ATTRIBUTES selection on the product page? (this is where you add in the variations of your attribute, like black, green, etc, for color)
    5. Check the VARIATIONS MENU within the product. On mine, I have several variations set up as follows:

    a) BLACK
    b) GREEN

    With this example, I have a dropdown menu for colour that says "choose an option", and if I click on the dropdown arrow, I see the options black or green. I can also edit these variations so one is a different price. Once the option is selected, the quantity and add-to-cart will appear (and a price, if they are different prices).

    This works well for me, perhaps you have missed a step.

  9. Pal74
    Member
    Posted 1 year ago #

    Hello! I have the same problem.
    I read first what you were suggesting and followed you instructions. I saved every single step when adding a new product.
    It did not help at all - it keeps deleting the check-box for "use for variation"
    What is more, the check sign already disappears when adding a product, save that step and go on with editing...

  10. sleepymonk
    Member
    Posted 1 year ago #

    I'm sorry I can't help further. It works for me, but I had to do trial and error to figure it out with my setup.

  11. maksbd19
    Member
    Posted 1 year ago #

    I had a similar problem but recently I've solved it.

    My problem was-

    1) variations wasn't showing up in the post editor.
    2) variations weren't showing in the product's front end page.

    For (1) I just followed the steps explained above

    For (2) there is a required field titled "Regular price" in the variation edit fields. When I set some value in there then those variations, in which i set the values, are started showing up in the product page.

  12. shynesobright
    Member
    Posted 1 year ago #

    Im new to this, but i was having the same problem. I would follow the steps for adding attributes and variations and would get nothing on the front end.But I found a solution!!!
    Go to Product> Attributes> Edit ( attributes)

    I changed my DEFAULT SORT ORDER from "custom" to "name". UPDATE, then check your page. The options should populate.

  13. Pal74
    Member
    Posted 1 year ago #

    Hello!
    This problem got solved for me few days ago, when I upgraded to version 2.0.8.
    Apparently special characters in attribution name made the trouble (I personally used numbers an "-" in attribution name)
    Now it works fine fmor me.

  14. ibrahimgoli
    Member
    Posted 1 year ago #

    Hi all

    I have a problem with attributions. I am using woocoomerce in Persian language. everything is OK but when Im adding color variation in Persian language it shows something like this
    $c%dRdpf%$icd%$% :D (example)
    but when I am using English, it is OK .
    anyone can help me please?

  15. djgritz
    Member
    Posted 6 months ago #

    I was just pulling my hair out over the same problem where I enter the options in "attributes" but nothing shows up on the drop down menu on the front end. The ticket, as an earlier poster suggested, was that there needed to be something in the "Price" field in the Variations section. Which makes sense, cause without it Woocommerce doesn't know how much $ to put in the cart when the user selects. Boom! Done. Thank you!

  16. Kych
    Member
    Posted 6 months ago #

    Hey! Pls Help! When I choose an attribute on the site from the drop down menu for ex size M ; color green; the drop down menu still shows "Choose an option" , it doesn't show what I've choosen (

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic