WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Variable products not working (6 posts)

  1. bolivares
    Member
    Posted 1 year ago #

    When using a variable product the Add to Cart button and Quantity field cease to be displayed

    I have a selected price for each variable yet it still doesn't work. I'm thinking it could have something to do with the quantity selector of that could possibly not be going through. I've tried deactivating all plugins with no luck.

    I'm using a modified version of Max Magazine and I believe I could have messed something up to cause this issue. I'm relatively new at this and am currently holding up this client due to the problem.

    Any help would be fantastic for I have been dealing with this for over a month and I just can't make any progress.

    Here's an example page of a product to test it http://www.coreytegeler.com/bolivares/shop/marquez-button-down-cardigan-2/

    http://wordpress.org/extend/plugins/woocommerce/

  2. IgniteWoo
    Member
    Posted 1 year ago #

    You might be missing some Javascript, or have the wrong IDs or class names in your HTML. The expected divs are in the page, but they're hidden as they should be until a variation is selected. But, when a variation IS selected the divs don't unhide.

    The class name of the hidden div us "single_variation_wrap"

  3. bolivares
    Member
    Posted 1 year ago #

    I've modified it to make sure the button is always displayed but I still get a "Please choose product options" message whenever I try to add a variable.

  4. virtualmediamavens
    Member
    Posted 1 year ago #

    I too am getting this same issue. Niether the "Variable Product" or the "Single Product" show a shopping cart. Even if I change the variables nothing happens. What gives?

  5. paryguy
    Member
    Posted 1 year ago #

    When you add your variations, are you making sure the drop-down list next to the variation ID is selected to the right attribute? This was the case for me when setting up variable products.

    You need to add your attributes, then save the product. After the update, add the variations and make sure that on the title bar of the variation you select which attribute it should be assigned to.

  6. bolivares
    Member
    Posted 1 year ago #

    Everything is set up correctly, I have switched to a different theme and everything works fine. There must be some conflict in my theme and I just can't figure out what it could be.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.