WordPress.org

Ready to get started?Download WordPress

Forums

Validation error (12 posts)

  1. smalls
    Member
    Posted 8 years ago #

    http://mafsmetsreport.twooldsaps.com

    I'm having a hard time understand my last 3 validation errors, and was wondering if some of you smart folks could help me out a little. Appreciate any help.

    http://validator.w3.org/check?uri=http%3A%2F%2Fmafsmetsreport.twooldsaps.com%2F

  2. Nazgul
    Member
    Posted 8 years ago #

    You open a <ul> tag followed by a <form> tag, but <form> tags aren't allowed directly within a <ul> tag. So either remove that <ul> (and corresponding </ul>) or put a <li> between them and a </li> between the closing tags.

  3. yosemite
    Member
    Posted 8 years ago #

    Wow, naz is fast ;')

    Looks like the offending code is in your 'Mets Poll'.

  4. smalls
    Member
    Posted 8 years ago #

    Yosemite,

    That's what I thought too. But it's the democracy plugin which I haven't modified at all. I look at the code, found the location, but didn't see any problem with the code.

  5. yosemite
    Member
    Posted 8 years ago #

    Democracy plugin titled 'Mets Poll'. You got it...

  6. smalls
    Member
    Posted 8 years ago #

    Yosemite,

    My code under the 'Mets Poll' is simply whats described in the help file"

    <h2>Mets Poll</h2>
    <ul><?php jal_democracy(2); ?></ul>

    I found in the democracy.php the location the validator is talking about, but didn't want to screw with that.

  7. yosemite
    Member
    Posted 8 years ago #

    Unfortunately that is the exact location screwage is required ;')

  8. smalls
    Member
    Posted 8 years ago #

    Yosemite,

    That's crazy. I deactivate the democracy plugin and everything is good. I activate it, and there are problems. Again, all I added to my sidebar is the code above. How would that cause any issues, or could there be a problem with the plugin?

  9. Nazgul
    Member
    Posted 8 years ago #

    Which version of that plugin are you running?

  10. smalls
    Member
    Posted 8 years ago #

    Nazgul,

    I'm using release: September 26, 2005 Version: 1.2. Thanks for the help

  11. smalls
    Member
    Posted 8 years ago #

    That's crazy. I deactivate the democracy plugin and everything is good. I activate it, and there are problems. Again, all I added to my sidebar is the code above. How would that cause any issues, or could there be a problem with the plugin?

    I'm using release: September 26, 2005 Version: 1.2.

  12. Nazgul
    Member
    Posted 8 years ago #

    What if you change your sidebar code to this (so remove the ul and /ul):
    <h2>Mets Poll</h2>
    <?php jal_democracy(2); ?>

Topic Closed

This topic has been closed to new replies.

About this Topic