WordPress.org

Ready to get started?Download WordPress

Forums

Valid XHTML? (9 posts)

  1. robinalex
    Member
    Posted 10 years ago #

    Hi all, first of all, I'd like to say how great wordpress and their users are :D
    That being said, I wanted to discuss a small problem I've been having. I keep getting a non-valid xhtml result page from the w3 validator. I've been trying to center images primarily, and I tried both <center> and <div align="center">, but w3 says that that's not allowed for both of them. Here's a look at the w3 page: http://validator.w3.org/check?uri=http%3A%2F%2Frobinalex.ceejaycee.net%2F
    Anyone know any other methods that ARE xhtml valid?
    Thanks in advance :)
    -Robin Alex
    http://robinalex.ceejaycee.net/

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    In css:
    .cent {
    text-align: center;
    }
    In post
    <div class="cent">
    blah blah
    </div>
    :)

  3. robinalex
    Member
    Posted 10 years ago #

    woah! thanks! really, thanks again :D

  4. robinalex
    Member
    Posted 10 years ago #

    haha, actually now it doesn't center the image ?:\ hm.. but i'll keep trying different things. if you or anyone else has anymore suggestions, I'm more than willing to take em :D

  5. Mark (podz)
    Support Maven
    Posted 10 years ago #

    You could have some conflicting css...
    If you post a picture using that css, I'll have a look ?

  6. davidchait
    Member
    Posted 10 years ago #

    Yeah. I think you can use the [center] in transitional, but you can't necessarily do it INSIDE the [a href]. try centering around the entire link, see if that works.
    Some things don't come up as valid inside a link -- which is ticking me off right now as certain styles of output from CG-Amazon aren't validating. Too freaking bad. How else am I supposed to have an image and text items that all function as a single link?? ;)
    -d

  7. robinalex
    Member
    Posted 10 years ago #

    "This Page Is Valid XHTML 1.0 Transitional!"
    Yes! that did the trick, looks like I had to put it outside the image AND href itself. But as you said there will be times when we need it to be valid from inside the link. I wonder why it's doing this .. hm... well thanks again guys, at least I got it working now :D

  8. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Cool :)

  9. mi327
    Member
    Posted 8 years ago #

    My amazon plugin also does not validate my page, all of my errors have to do with my amazon posts. Can anyone help?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.