WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Valid URL gives "URL seems invalid" (11 posts)

  1. Number 6
    Member
    Posted 1 year ago #

    This is just a heads-up for the developer of a URL which is being misidentified as invalid when the form is submitted.

    http://wis-wander.weizmann.ac.il/weather-on-the-outer-planets-only-goes-so-deep/

    I'm guessing it's something to do with the number of levels in the domain maybe combined with the dash in the "wis-wander" subdomain.

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    The URL is valid. I didn't see validation error when I tested it on my environment.

  3. Number 6
    Member
    Posted 1 year ago #

    Hi, thanks for replying :-)

    Strange, it definitely fails to validate on mine. If I remove the dash from "wis-wander" then validation is successful.

    I've tested in Firefox 20.0.1 and Google Chrome 26.0.1410.64 m and get the same result.

    I'm using Contact Form 7 version 3.4.1 on a WordPress 3.5.1 installation with the default jQuery 1.8.3, and jQuery UI Core 1.9.2

  4. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Can I see the site? Also, what plugins and theme do you use?

  5. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    What version of PHP do you use? If possible, try upgrading it to the latest version. There seems to be a PHP bug relating to this.

  6. Number 6
    Member
    Posted 1 year ago #

    Yes that's no problem, but could I send the details to you privately?
    We've had some directed attacks to our server in recent months and I'd prefer to keep the server details from being easily found in public if possible.

  7. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    That's OK if it's difficult to be public. Just try upgrading PHP.

  8. Number 6
    Member
    Posted 1 year ago #

    I'm currently using a shared server so unable to update PHP, however I also have a local development box with xdebug so will do some testing on there along with disabling plugins, etc.

    I'll let you know what I find :-)

  9. Number 6
    Member
    Posted 1 year ago #

    Everything was fine on my development box (PHP 5.4.6-1ubuntu1.2), and the validation passed.

    The PHP version on the live server where the validation fails is 5.3.2-1ubuntu4.19

    I'll see if I can get the shared hosting updated to a more recent version of PHP.
    Thanks for your help :-)

  10. ImNotLost
    Member
    Posted 1 year ago #

    Where can I find the validation code? I'd like URLs both with and without http:// to be valid.

  11. truck808
    Member
    Posted 9 months ago #

    Hi. I'm having a problem where http://www.domain.com seems invalid but https://www.domain.com works fine. Any way around this?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic