WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
[resolved] V2.0.2 having issue on "headers already sent" Cause Cache Failure (3 posts)

  1. Ryan Harne
    Member
    Posted 1 year ago #

    Hi there,

    Latest version 2.0.2, reported PHP Warning:

    headers already sent by (output started at /not..real..path/wp-content/plugins/all-in-one-seo-pack/aioseop_class.php:1143) in ....

    These making W3-Cache page-cache (any method) crashed with an output of 500 Error.

    Reverted to 2.0.1 until further updates.

    Thanks!
    Ryan H

    http://wordpress.org/extend/plugins/all-in-one-seo-pack/

  2. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    Ryan,

    Thanks for the report; I can't reproduce this on my test site with the latest versions of the All In One SEO Pack and W3 Total Cache plugins, using the Disk Enhanced method to test the page cache. The line referenced is where All In One SEO Pack outputs its information for wp_head - this should not be getting called before the page is rendered, i.e., before headers would be sent. Is there anything else you can tell me about your configuration that might be unique or helpful here, or could you try this for me on a test site to narrow down the cause?

  3. Ryan Harne
    Member
    Posted 1 year ago #

    Hi Peter,

    Appreciate for your prompt response.
    Unfortunately I can't replicate this issue on site other environment as well.
    It must be other plugin / server issue.
    Let me closed this first, until I found the real issue.

    Thanks again.
    Ryan H

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic