WordPress.org

Ready to get started?Download WordPress

Forums

Catch Box
v1.5.4 breaks single column (14 posts)

  1. rafdizzle86
    Member
    Posted 1 year ago #

    I just upgraded to v1.5.4 and selected the "one-column, no sidebar" option for the catchbox theme. After hitting "save changes", the sidebar still shows up on the right.

    Help Please!
    Thanks!

  2. rafdizzle86
    Member
    Posted 1 year ago #

    I had to downgrade to 1.5.3 to get it so it shows the "one-column, no sidebar" layout. You can find the 1.5.3 zip in this thread: http://wordpress.org/support/topic/theme-catch-box-version-update.

    Hopefully the issue will be fixed soon??

  3. Christopher2
    Member
    Posted 1 year ago #

    Hi Sakin
    I have made both updates, function.php and styl.css,1.5.5 but still having problems to get the theme filling the screen.

    Please have a look here:
    https://dl-web.dropbox.com/get/Public/screenshot1.jpeg?w=4a201ebc

    Thanks in advance

  4. duyarfatih
    Member
    Posted 1 year ago #

    yes thats right rafdizzle86. i see this problem vs 1.5.4 and i turn vs 1.5.3 this problem is resolved.

    1.5.4 "no sidebar style" problem

  5. Catch Themes
    Member
    Theme Author

    Posted 1 year ago #

    Please update to Version 1.5.5 and it will be fine.

  6. rafdizzle86
    Member
    Posted 1 year ago #

    Looks like it fixed it!

    However I've noticed another issue: post width vs page width are different. Pages are a lot wider than posts - is this an intended feature? I'm sure it's easily fixed with some CSS.. but figured I'd give you a heads up.

    Thanks!

  7. Catch Themes
    Member
    Theme Author

    Posted 1 year ago #

    @rafdizzle86: can you send me screenshot or send me your site URL.

  8. rafdizzle86
    Member
    Posted 1 year ago #

    Sure, here is the URL for a page:

    http://www.rafilabs.com/contact-me/

    And here is a URL for a post:

    http://www.rafilabs.com/quicktags-plugin/

    The page width is a lot wider than the post width.

    Thanks!

  9. rafdizzle86
    Member
    Posted 1 year ago #

    I also realized another "bug": if you look at posts on - on the bottom there seems to be another sidebar area above the footer. On my site it currently contains two widgets: "Archives" and "Meta". I don't think either should be there considering I can't even access those widgets from my dashboard!

    Thanks!

  10. Catch Themes
    Member
    Theme Author

    Posted 1 year ago #

    @rafdizzle86: I see that you have selected "One-column, no sidebar" in Theme Option. This option is for all post and pages. But I see that in page "http://www.rafilabs.com/contact-me/" you have selected the custom template "Full Width Disable Sidebar Template". Now in these pages you just select the "Default Template". Then the post and paged will have same design.

  11. Catch Themes
    Member
    Theme Author

    Posted 1 year ago #

    @rafdizzle86: when you select "One-Column, no sidebar". It shouldn't show the sidebar. But I couldn't recreate the bug you found with widget. So, can you give a try by replacing your sidebar.php with http://themes.svn.wordpress.org/catch-box/1.5.5.1/sidebar.php

  12. rafdizzle86
    Member
    Posted 1 year ago #

    Thanks for the feedback @Sakin! I changed the template for the pages and it fixed the issue.

    As for the widget area above the footer - I realized what's wrong: My 'sidebar-1' didn't have any widgets in it, so it defaulted to the archive and meta widgets. I changed sidebar.php to the following:

    <?php if(is_active_sidebar( 'sidebar-1' )){ ?>
    <div id="secondary" class="widget-area" role="complementary">
     <?php dynamic_sidebar( 'sidebar-1' ) ?>
    </div><!-- #secondary .widget-area -->
    <?php } ?>

    This way it will only render the sidebar if there are any active widgets added to it. Otherwise it won't render anything in that area.

    Hope this help!

  13. Catch Themes
    Member
    Theme Author

    Posted 1 year ago #

    @rafdizzle86: You don't need to do that as if you have selected the disable sidebar. There shouldn't be sidebar. So, the code in sidebar.php will be as following:

    <?php
    /**
     * The Sidebar containing the main widget area.
     *
     * @package Catch Themes
     * @subpackage Catch_Box
     * @since Catch Box 1.0
     */
    
    $options = catchbox_get_theme_options();
    $layout = $options['theme_layout'];
    
    if ( $layout == 'content-onecolumn' || is_page_template( 'page-disable-sidebar.php' ) || is_page_template( 'page-fullwidth.php' ) ) :
    	return false;
    else :
    ?>
    		<div id="secondary" class="widget-area" role="complementary">
    			<?php if ( ! dynamic_sidebar( 'sidebar-1' ) ) : ?>
    
    				<aside id="archives" class="widget">
    					<h3 class="widget-title"><?php _e( 'Archives', 'catchbox' ); ?></h3>
                        <div class="widget-content">
                            <ul>
                                <?php wp_get_archives( array( 'type' => 'monthly' ) ); ?>
                            </ul>
                        </div>
    				</aside>
    
    				<aside id="meta" class="widget">
    					<h3 class="widget-title"><?php _e( 'Meta', 'catchbox' ); ?></h3>
                        <div class="widget-content">
                            <ul>
                                <?php wp_register(); ?>
                                <li><?php wp_loginout(); ?></li>
                                <?php wp_meta(); ?>
                            </ul>
                      	</div>
    				</aside>
    
    			<?php endif; // end sidebar widget area ?>
    		</div><!-- #secondary .widget-area -->
    <?php endif; ?>
  14. rafdizzle86
    Member
    Posted 1 year ago #

    Ah - your code is different than what is in the current sidebar.php for v1.5.5 (most recent version I believe). Here is the current code if you download v1.5.5:

    <?php
    /**
     * The Sidebar containing the main widget area.
     *
     * @package Catch Themes
     * @subpackage Catch_Box
     * @since Catch Box 1.0
     */
    
    $options = catchbox_get_theme_options();
    $current_layout = $options['theme_layout'];
    
    if ( 'content' != $current_layout ) :
    ?>
    		<div id="secondary" class="widget-area" role="complementary">
    			<?php if ( ! dynamic_sidebar( 'sidebar-1' ) ) : ?>
    
    				<aside id="archives" class="widget">
    					<h3 class="widget-title"><?php _e( 'Archives', 'catchbox' ); ?></h3>
                        <div class="widget-content">
                            <ul>
                                <?php wp_get_archives( array( 'type' => 'monthly' ) ); ?>
                            </ul>
                        </div>
    				</aside>
    
    				<aside id="meta" class="widget">
    					<h3 class="widget-title"><?php _e( 'Meta', 'catchbox' ); ?></h3>
                        <div class="widget-content">
                            <ul>
                                <?php wp_register(); ?>
                                <li><?php wp_loginout(); ?></li>
                                <?php wp_meta(); ?>
                            </ul>
                      	</div>
    				</aside>
    
    			<?php endif; // end sidebar widget area ?>
    		</div><!-- #secondary .widget-area -->
    <?php endif; ?>

    The if statement: if ( 'content' != $current_layout ) : condition is different than what you listed in your code. Perhaps your code has yet to be checked into the most recent version?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic