WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] UTW tags import blank error (11 posts)

  1. titanas
    Member
    Posted 6 years ago #

    Importing approx 6500 tags from UTW to WP 2.3 leaves me with a blank page with the message "Adding Tags to Posts…". That's all i see after clicking on Step 3 buttong. Any ideas?

    regards

  2. Jeremy Clark
    Moderator
    Posted 6 years ago #

    Most likely importing that many tags php is time out. Check your server logs and see about any php errors. If you already have a .htacces file in your root directory try adding this to see if it clears up the problem

    php_value set_time_limit 300

    This will set the time out limit of php to 5 minutes which should be enough time.

  3. titanas
    Member
    Posted 6 years ago #

    Thanks for the quick reply. I figured out that there was something wrong in the DB. Deleting 4 tags resolved the problem partially. Now except from the message "Adding Tags to Posts…" i'm getting a bunch of error messages like the following:

    WordPress database error: [Duplicate entry '' for key 2]
    INSERT INTO wp_terms (name, slug, term_group) VALUES ('νάουσα', '', '0')

    WordPress database error: [Duplicate entry '0-post_tag' for key 2]
    INSERT INTO wp_term_taxonomy (term_id, taxonomy, description, parent, count) VALUES ('0', 'post_tag', '', '0', '0')

    WordPress database error: [Duplicate entry '3423-0' for key 1]
    INSERT INTO wp_term_relationships (object_id, term_taxonomy_id) VALUES ('3423', '0')

    WordPress database error: [Duplicate entry '' for key 2]
    INSERT INTO wp_terms (name, slug, term_group) VALUES ('νάουσα', '', '0')

    WordPress database error: [Duplicate entry '0-post_tag' for key 2]
    INSERT INTO wp_term_taxonomy (term_id, taxonomy, description, parent, count) VALUES ('0', 'post_tag', '', '0', '0')

  4. titanas
    Member
    Posted 6 years ago #

    I think using HTML entities for displaying greek characters is something that WP 2.3 tags don't like..

  5. titanas
    Member
    Posted 6 years ago #

    Deleting the "greek tags" resolved the SQL errors but adding the php_value set_time_limit 300 didn't help. Still seeing this blank "Adding Tags to Posts…" page after clicking on Step 3 button

  6. Jeremy Clark
    Moderator
    Posted 6 years ago #

    Sometimes host don't allow php directives in htaccess files. Check your server logs after trying to import your tags and see if php timing out is really your problem and if it is see if your host can increase the time out for you.

  7. titanas
    Member
    Posted 6 years ago #

    Im on a VPS but i'll give it a try and let you know. Thanks man.

  8. titanas
    Member
    Posted 6 years ago #

    It's definitely not a PHP timeout issue. I had another script running for 500sec and everything was fine when it completed its job.

  9. titanas
    Member
    Posted 6 years ago #

    Not sure if this is an UTW importer has issue or a MySQL / Apache config issue but i figured out that cutting down from 6000 to 1000 tags [wp_tags] and from 21000 to 13000 relations [wp_post2tag] the importer works.

    Thinking of a solution based on the success of this test.

  10. titanas
    Member
    Posted 6 years ago #

    It was a timeout and possibly memory issue. In /etc/php.ini set

    max_execution_time = 3600
    memory_limit = 64M [at least for such huge operations. set back to normal value again]

    restart apache. In RedHat /etc/init.d/httpd restart

    Run the import script again

  11. FunkyDung
    Member
    Posted 6 years ago #

    I tried adding the php_value set_time_limit setting to my htaccess file, but it caused a 500 error, so I had to remove it. Is there a particular part of the file I should place that?

Topic Closed

This topic has been closed to new replies.

About this Topic