WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] UTF8 Problem, incorrect display of special characters... (é, É, å, ä, ö etc.) (7 posts)

  1. AdmiralGanja
    Member
    Posted 4 years ago #

    Hi everyone,

    I have set UTF8 Encoding on my site (from source):

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US">
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" >

    STILL i get incorrect encoding:
    http://wilfing.se/forum/utf8encoding.jpg

    I have tried to remove the two lines according to some forums on the web to fix this without any results:
    //define(‘DB_CHARSET’, ‘utf8′);
    //define(‘DB_COLLATE’, ”);

    The problem occurs both from DB sources as well as hard coded text meaning that it shouldn't be my DB that is the reason for this.

    Please help me as I am desperate :)

    Thanks in advance...
    Jesper Wilfing

  2. AdmiralGanja
    Member
    Posted 4 years ago #

    Hi,

    After trying zillions of solutions I finally found that Notepad++ my editing program was using ANSI encoding, possibly the files that I got also somehow was set to ANSI encoding. By using Notepad++ and converting all PHP files to UTF-8 it suddenly started to work.. I will need to re-write all posts though for some reason. Maybe because they were created in ANSI mode, it just won't show it correctly in UTF8.

    I am no character encoding expert but maybe this information cpuld help someone out there.

    http://wilfing.se/forum/utf8.png

  3. nau
    Member
    Posted 3 years ago #

    you're a life saver man..i went through the same problem and found that my PHP editor was set to ANSI

    Thanks so much

    Finau

  4. princechrisvic
    Member
    Posted 3 years ago #

    I'm having the same problem inserting these following characters.
    Ị ị Ọ ọ Ụ ụ Ṅ ṅ . Could you guys tell me which of the php templates you converted. Please save a soul. It is really a nightmare

  5. agence
    Member
    Posted 3 years ago #

    Open and edit your WordPress wp-config.php file. Then locate the following two lines:

    define(‘DB_CHARSET’, ‘utf8′);
    define(‘DB_COLLATE’, ”);

    You can simply delete these 2 lines away, or just remove the utf8 from the first line to make them looks like this:

    define(‘DB_CHARSET’, ”);
    define(‘DB_COLLATE’, ”);

  6. deafischer
    Member
    Posted 3 years ago #

    Hi guys, I am having the same problem, with the exception that I call the wp posts from another homepage, no wp inside.
    Our whole system is iso-8859-1 and only the peace of script (the_loop()) from wp comes in utf-8. I have tried lots of stuff, and like all above, I am getting nuts!
    Does anyone see a light after the tunnel??????
    Thanx for reading!
    Andrea

  7. vdudak
    Member
    Posted 3 years ago #

    Hi guys, same problem with coding, however, for my site doesn work any trick. It's problem of current template what I'm using at the site at the oment. What do you thing it will works?

    Site with issue: http://brnobezrealitky.cz/

    I'm really struggling with charset encoding.

Topic Closed

This topic has been closed to new replies.

About this Topic