WordPress.org

Ready to get started?Download WordPress

Forums

Audio Player
UTF8 and Unicode files "No File Found" (1 post)

  1. KirbyTank
    Member
    Posted 1 year ago #

    Hi, using latest wpaudioplayer. However, using the standalone version.

    Somehow, the player says "File Not Found" when the mp3 file is in Chinese.
    The page is here:

    http://takusbox.com/index.php/music-ministry/albums-cds/chen-chi-ren-zhuan-yue.html
    The script auto generates this based on file name. For example: Track 4 is named "04_愛意情懷.mp3" Thus, on frontend the track name and lyrics is auto generated. So, to me the file name is very important.

    When looking at the code for Track 4, it looks like the file location is correct. However, when trying to play it shows "File Not Found".

    <object id="audioplayer_4" width="290" height="24" type="application/x-shockwave-flash" name="audioplayer_4" style="outline: none" data="http://takusbox.com/components/com_content/plugins/audio/player/player.swf">
    <param name="wmode" value="opaque">
    <param name="menu" value="false">
    <param name="flashvars" value="soundFile=http://takusbox.com/media/audio/Mike/AllLongsForYou/04_愛意情懷.mp3&playerID=audioplayer_4">
    </object>

    To be sure this is working properly, Track 6 (Latin based file name) plays very nicely.
    Is there a fix for this? Thanks, would appreciate if you look into it.

    http://wordpress.org/extend/plugins/audio-player/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic