WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] UTF-7 of death! WP bug (3 posts)

  1. Niemi
    Member
    Posted 7 years ago #

    Hello

    I have had a lot of trouble finding an appropriate charset, so I was trying some different ones. I was changing them under options >> reading >> Charset (standard is UTF-8)

    I typed "UTF-7" and was asked if I wanted to save the changes. I never should've done that. Now I'm left with a lot of ᅢᅢᅢᅢᅢᅢᅢ's and I can't change it back to UTF-8. It now says UTF-7 and every time i try to change it to something else, it does'nt change anything. Still says UTF-7...

    Ever since i typed "UTF-7" in the charset my blog has been acting very weird. Everytime i change anything or post anything it ask me to confirm the change with a "do you really want to change... "

    When I post something new, the title doesn't show up. This surely MUST be a disastrous WordPress bug. Others have mentioned the exact same problem but only one found a solution. I don't get the solution so that didn't help much. http://www.efipo.com/20061113/tech-support-almost-ruined-me/

    HELP ME! My WordPress is screwed up and i don't have a proper backup.

    My site: http://www.kreativpotens.dk

  2. moshu
    Member
    Posted 7 years ago #

    I can't advice anything better than what is described in these 3 posts:
    http://wordpress.org/support/topic/67837?replies=9#post-359416

  3. Niemi
    Member
    Posted 7 years ago #

    Complete guide to fix the grim WordPress UFT-7 bug:

    1. First open PhpMyAdmin, your domain host can provide you with the adress, in my case it's http://phpmyadmin.needhost.dk/.

    Login with the username and password you would have specified when creating the database.

    2. A list of your databases will appear. Click the one that is your WordPress database. All the tables in your database will appear. Depending on what prefix you have specified in your wp-config.php file you should find something like wp_options. If you can't find this table you prefix isn't wp_. You can look op wp-config.php at the root of your wordpress directory, and find the prefix line.

    example: $table_prefix = 'anotherprefix';

    In this case the table in your database would be ilovewordpressbugsoptions.

    Open the table "wp_options" or "anotherprefixoptions".

    3. Now you should look for the column named option_name. Look through the list and see if you can find an option called "blog_charset". Typically option_id #37. If you can't find it it's because it's on the next page. Click the next page button.

    4. Now you have found the "blog_charset". If you look at the value it says "UTF-7". Because WordPress can't handle this we are going to change this to UTF-8. Click the pen just before the delete function to edit it.

    5. Find the field where it say "UTF-7" and change it to "UTF-8" and press done, or whatever it's called in your language, at the bottom of the page.

    6. Thank God. You're done!

Topic Closed

This topic has been closed to new replies.

About this Topic