WordPress.org

Ready to get started?Download WordPress

Forums

Using wordpress from computer on the LAN of the web server (2 posts)

  1. bondiblueos9
    Member
    Posted 6 years ago #

    My apologizes if this is already addressed somewhere else. I could not find it.

    Currently, I have a web server installed on a computer on my LAN, and wordpress is installed on that server. I want to be able to use wordpress from a browser on that computer, on other computers on my LAN, and on other computers out on the internet.

    After install, wordpress was working fine from the computer it was installed on, but when I went to the general settings and I changed the wordpress address and blog address from http://localhost/wordpress to http://www.mydomain.com/wordpress, it tried to load everything from http://www.mydomain.com/wordpress. While this is what I wanted, the computer failed to connect to itself; the other computers could not connect either, even using the LAN address of the server. I've never been able to use my domain name from inside my network, but I wasn't expecting to have to; I was expecting wordpress to use the address in the settings for any absolute links it had to create, not for every link in the entire site.

    Furthermore, when the wordpress and blog addresses in the settings were set to http://localhost/wordpress, the other computers on the network would try to access themselves at localhost instead of the provided LAN IP of the server.

    Currently, my workaround is to set the addresses in the settings to http://www.mydomain.com/wordpress and change the hosts files on my computers to point http://www.mydomain.com to the LAN IP address of my server.

    Additionally, a related but different issue I had, was that when I changed the addresses in the settings, links to files I had uploaded in my posts did not change to the new address, and so were broken. For instance, if in a post I had clicked the Add Media button and
    uploaded a file, the link in the post to that file would be http://localhost/wordpress/?attachment_id=4 but then if I changed the addresses in the settings, the link in the post would remain as http://localhost/wordpress/?attachment_id=4

    Any advice would be appreciated, even if its "Follow this link to this FAQ that you missed"

  2. whooami
    Member
    Posted 6 years ago #

    I cant speak to the second problem, but the solution was one you are using -- dont use localhost. localhost for you is you, localhost for me is me -- whether were on a lan or a wan.

Topic Closed

This topic has been closed to new replies.

About this Topic