WordPress.org

Ready to get started?Download WordPress

Forums

Using the word " " (23 posts)

  1. cvincent
    Member
    Posted 9 years ago #

    I'm having a strange problem using the word "compress" here:
    http://frame-by-frame.net/

    WordPress seems to replace the word with a bunch of spaces. It happens in the title and the first occurence in the body of the entry. Additionally, using the word in the post slug made the permalink impossible to reach (though if there was a change in the slug, it didn't show up in the WordPress interface).

    I got around it by starting the title of the post with the word "compression" so that the C would be capitalized (which apparently doesn't trigger the effect), and then capitalizing the word in the post body but making it lowercase using CSS. I had to take the "o" out in the slug because the slug is always lowercase.

    This is kind of a strange problem. Anyone know what's up? I'd look at the PHP and track it down, but I can't from where I am.

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Very occasionally, a WP user posts with just such a problem - a certain word that screws things up in some way.
    As far as I recall, there has been no cure because the circumstances are different in each case and the user invariably finds another word to use. And if there was a cure, it has never been posted back here.

    This might have to be chalked up to "Strange Oddity" :)

  3. cvincent
    Member
    Posted 9 years ago #

    Apparently the word " " is somewhat consistent, as it was also removed from the title of this thread! :P

  4. cvincent
    Member
    Posted 9 years ago #

    Grr... there it went again!

  5. ifelse
    Member
    Posted 9 years ago #

    FYI, I've tried submitting a post entitled compress and that went through fine.

  6. Dougal Campbell
    Member
    Posted 9 years ago #

    What plugins do you have active?

  7. TheStar
    Member
    Posted 9 years ago #

    cvincent, post the word, but put a - in between each letter. That should do the trick :)

  8. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    Who is your host?

  9. cvincent
    Member
    Posted 9 years ago #

    My host is MediaTemple. The only plug-ins I have active are a few custom hacks of my own (which surely wouldn't be the problem) and the Markdown plug-in.

    I should also mention that it's using WordPress 1.5.

    I don't think that this is an issue specific to me, considering that the word " " was removed from this forum as well (and isn't this forum based on WordPress? I'm not sure on that one).

  10. cvincent
    Member
    Posted 9 years ago #

    lol...

    It was removed from the above post as well, where the quotes are. "Compress". " ". compress.

  11. Heatsink
    Member
    Posted 9 years ago #

    Anything to do with gzip compression being turned on?

    Yes...it's stupid...but you never know.

  12. DarkCryst
    Member
    Posted 9 years ago #

    So its just compress between quotes like "compress" or any instance of the word...

    actually I guess this post will test that on the forums.

    Something this wierd I chalk up to regular expressions, when something wierd happens its usually their fault. You can't get wierder than regex.

  13. Dougal Campbell
    Member
    Posted 9 years ago #

    Next question: if you go back to edit a post with the word "compress" in it, does the word show up in the edit view? In other words, is it still in your original text and it's only being filtered on output?

  14. F10
    Member
    Posted 9 years ago #

    Well, that is a wierd one.... I tested a post with the word compress in the title and in the body and both display normally. WP 1.5.

  15. WebCudgel
    Member
    Posted 9 years ago #

    Have you checked out the Comment Blacklist under Options/Discussion? Not sure if that might cause some of this quirkiness. (BTW, beautifully done website)

  16. cvincent
    Member
    Posted 9 years ago #

    Heatsink: No gzip.

    DarkCryst: It doesn't seem so consistent here in the forums, but it is happening now and then. On Frame By Frame, it only seems to happen to the first occurence of the word in the body of the entry, and only if it appears in all lowercase letters. Surrounding it with quotes, making it part of a word (such as "compression" on Frame By Frame), etc. doesn't have an effect; the term "compress" is still removed.

    Dougal: Nope, the word is also removed when I go back to edit the post. I haven't checked whether the word is removed in the database, but it's removed everywhere it's displayed within WordPress.

    WebCudgel: Compress isn't in the blacklist, but like you said, I doubt it would have this effect. (Thanks for your compliment :))

    Still trying to figure this out. Thanks, everyone! :)

  17. cvincent
    Member
    Posted 9 years ago #

    Quick update: I just edited the article from my home computer, and none of the previous effects occurred. That's still strange though, because this is the same computer from which I originally published it.

    Anyways, the problem is solved on the short term. I'll see if I can find the source of it if it ever comes up again. Thanks for the help, everyone!

  18. Mark (podz)
    Support Maven
    Posted 9 years ago #

    This post - http://wordpress.org/support/topic.php?id=20758 - never was solved .......

  19. Dougal Campbell
    Member
    Posted 9 years ago #

    Hrmmm.... cvincent: I'm not sure if you answered the question I intended to ask (I might have been unclear). When you edit the previously published post, and you are in the "Write Post" screen, is the word "compress" showing up there?

    Curious about the similar problems with the word 'curl'. Since 'compress' and 'curl' are both words that also have technical meanings within PHP, or generally on *nix hosts, it could be something that's not actually WordPress-specific.

    Could there be some relation to the previous issue with PHP/Zend version mismatches? Maybe even a host with some mod_security rules that are too general? The more I think about it, the more I think that this could be the right trail to follow.

  20. ceo
    Member
    Posted 9 years ago #

    It apparently IS curl...but not just the word, it only continues to be a problem if accompanied in this sentence:
    "Rather she decided to curl up in a ball in the corner of the room."

    I can delete everything up to curl and get a 403, but once it's gone everything is fine. Though just the word curl isn't causing it...ok, now I'm really confused.

    EDIT: after testing a bit more, if "curl" (small c) is the first word of a post, it'll also 403. I can't seem to recreate the issue any other way, sans with the above sentence in part or whole.

  21. Kelson
    Member
    Posted 9 years ago #

    I don't know about the compress problem, but the curl issue sounds like it might be related to mod_security rules. Some of the example rules block anything that looks like an attempt to fire up curl via a malicious web request.

    Ask your host whether they're using Apache with mod_security, and if so, whether they have any rules with curl or compress in them.

  22. ceo
    Member
    Posted 9 years ago #

    You are my hero Kelson. I contacted my host and they explained that it is an issue that has come up before due to possible exploits of those words. As such, they're unwilling to alter anything, but it's not that big of a deal as the word "curl" isn't exactly something I use all the time.

    I'm just happy to know what the problem was. Thanks so much!!

  23. Kafkaesqui

    Posted 9 years ago #

    "'curl' isn't exactly something I use all the time"

    But when you do, you could always try to fool 'em :

    & #99;url
    & #99;ompress

    Clean up the spaces, of course.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.