WordPress.org

Ready to get started?Download WordPress

Forums

WP Parallax Content Slider
[resolved] Using the slider in my static home page (15 posts)

  1. Pauloscorps
    Member
    Posted 1 year ago #

    Hi,

    I'm trying to implement you very great plugin in my home page.
    It is a static page so I put the slide code in my page.php template.

    It works, but the slider is loading a post content instead of the content of my page.

    I tried put it in different positions but the issue stay the same.

    How can I fix it ?

    Here is my code :

    <?php if(is_front_page()) {
    if ( function_exists( 'get_wp_parallax_content_slider' ) ) { get_wp_parallax_content_slider(); }
     } ?>

    Thank's in advance.

    http://wordpress.org/extend/plugins/wp-parallax-content-slider/

  2. wp-maverick
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Pauloscorps,
    once you've put the code in your static page PHP template, you have to choose between 2 modes for the slider in the admin panel.

    As it is described in the FAQ:
    - Static : The slides will be those which are defined in the file static-slides.php
    - Dynamic : The slides will be generated from your posts

    The slider doesn't load pages content!

  3. Pauloscorps
    Member
    Posted 1 year ago #

    Thank you for your answer.
    In fact, the slider works well but a post content is displayed UNDER the slider (instead of the content of my page).

    I want a latest posts slider on my homepage, so if I switch to static I won't be able to do this anymore, right ?

  4. wp-maverick
    Member
    Plugin Author

    Posted 1 year ago #

    Yes,
    switching to static mode is not the right thing to do.

    If you remove the slider code from your template's page, are you able to see your page content? or does it display also a post content?

  5. Pauloscorps
    Member
    Posted 1 year ago #

    Yes, if I remove the code, I have the content of my page like it has to be.

    Here is the page where you can see my issue :
    http://www.paulineghiazza.fr/

    It seems that it's the content of the last slide post.

  6. wp-maverick
    Member
    Plugin Author

    Posted 1 year ago #

    Can you tell me which theme you use for this blog?
    And can you try to limit the slide number to 3 and then look if the content is the last slide's one?
    Thanks

  7. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    These are English language forums. Please use English.

  8. Pauloscorps
    Member
    Posted 1 year ago #

    J'hésitais à passer en français, au cas où quelqu'un d'autre aurait le même soucis ;)

    Le thème est BigBangWP de Brankic1979.

    Effectivement, si je limite le nombre de slides à 3, c'est bien le troisième article qui est affiché.

  9. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    These are English language forums. Please use English.

  10. wp-maverick
    Member
    Plugin Author

    Posted 1 year ago #

    OK, so I'll check what's going on with this theme.
    For further (and french) explanations, you can switch to my website.
    I'll post here the answer when it will be resolved!

  11. Pauloscorps
    Member
    Posted 1 year ago #

    Thank's a lot for your time !

  12. wp-maverick
    Member
    Plugin Author

    Posted 1 year ago #

    The theme isn't free so it will be hrd for me to test it.
    When I try on other themes, I can't reproduce this error :(

    Your code should look like this in page.php file:

    ...
    get_header();
    if(is_front_page())
    {
        if ( function_exists( 'get_wp_parallax_content_slider' ) ) { get_wp_parallax_content_slider(); }
    }
    ?>
            <div id="primary">
    ...

    I'll try something else tomorow but just look one more time if your code is placed where it has to be and not in the loop.

    Let me know!

  13. wp-maverick
    Member
    Plugin Author

    Posted 1 year ago #

    I've just seen on your blog that your problem seems to be fixed!
    That would be nice to tell us what you've done to resolve it ;)
    PS: Your website looks great!

  14. Pauloscorps
    Member
    Posted 1 year ago #

    Yes, the problem is solved !
    I don't really know why, but I put the slider outside of the div it was in and it works.
    I know it's a little weird, but it's probably due to an incompatibility with the theme I use.

    Thank's again for all your support and for this wonderful slider. I'll do a donation, you really deserve it.

    PS : Thank's ;) and sorry I haven't replied sooner.

  15. wp-maverick
    Member
    Plugin Author

    Posted 1 year ago #

    You're welcome,
    I'm always glad to see this slider on other websites and yours is really really nice!
    Regards ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.