WordPress.org

Ready to get started?Download WordPress

Forums

using ssl with wordpress does not work (7 posts)

  1. j3design
    Member
    Posted 4 years ago #

    I can't seem to get any of my new wordpress site pages to be secure at all, all of them give me a browser error "to many redirects"

    I talked with my hosting provider and they said its an issue with wordpress, because my (non wordpress) live site works with ssl https://www.domain.com/

    But the new "wordpress" site does not work with https SSL
    https://www.domain.com/index_dev.php/products-page/checkout/

    So I know the certificate is working. Just not on my new wordpress site.

    I am running the latest version of wordpress, and the latest version of wp ecommerce. I have these plugins installed and active:

    All-In-One Cufón
    GigPress
    HTTPS for WordPress
    WP E-Commerce Weight & Destination Shipping Modules
    WP Shopping Cart

    Basically all pages in the wordpress site will not work with https, not just the wp ecommerce pages. All return the same browser error, "Page will not load, to many redirects"

    Does anyone know a fix for this?

    d

  2. j3design
    Member
    Posted 4 years ago #

    Thanks, But all that seems to do is force admin to be secure, when I go to my actual pages those still return the same error, "to many redirects" when I use https.

    I did not try any of the other things on that page you sent under "Further Information" because it said it was information in case you're using an older version of WordPress or your SSL setup is somewhat different (ie. your SSL certificate is for a different domain).

    I am using the latest version of wordpress and my certificate is for my domain name.

    Seems like it should be pretty straight forward, do I have to have two installs of workpress one using ssl? seems like a hassle.

    Any other suggestions?

  3. zthornto
    Member
    Posted 4 years ago #

    looking for a fix to this exact same issue.....

  4. amd08
    Member
    Posted 4 years ago #

    anyone find anything on how to resolve this issue?

  5. johnh44
    Member
    Posted 3 years ago #

    The answer, since WordPress is so lame about it, is to put your e-commerce outdice the WordPress environment, separate pages that can be secured. This is idiotic, but after a week of trying every tip, hack, plugin available from this site and many others, I have found nothing that works simply and efficiently with WordPress.

    I I even find a solution, I will post it here.

  6. kitchin
    Member
    Posted 3 years ago #

    Johnh44, did the plugin "WordPress HTTPS" fix your issues?
    I found this in your post history: http://wordpress.org/support/topic/plugin-wordpress-https-wordpress-https-options-are-not-showing-in-settings-and

Topic Closed

This topic has been closed to new replies.

About this Topic