WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Using Shared SSL w/ a Subdirectory Install (10 posts)

  1. seregon
    Member
    Posted 2 years ago #

    Hi there.

    I recently started a Bluehost site where, among other things, I want to put a WordPress blog. I installed it automatically through their cPanel, and I dropped it into a subdirectory of my main site.

    Just for my own peace of mind, I'd like to at least log in, if not administer, my blog over SSL. But I'm having a bit of trouble doing this when it comes to the shared SSL connection.

    To use SSL with bluehost, one uses a URL like https://secure.bluehost.com/~username/blog/wp-admin/ to access it. However, I have bluehost.com/~username/blog setup to be a subdomain redirect (also automatically set up in cPanel) to blog.mydomain.com instead.

    This is causing me a headache trying to login over SSL, as I can reach the wp-login page, but everything else is getting automatically redirected to blog.mydomain.com/~username/blog/..., which is generating 404 errors. [That request would actually translate into http://mydomain.com/~username/blog/~username/blog, which doesn't exist.]

    I'm thinking I might be able to solve this with some .htaccess trickery, but in the meantime I wanted to ask the people more familiar with WP than I if there's a setting or two I could tweak in the back end of WP to solve this issue. Has anyone had experience with this?

  2. ce_bradm
    Member
    Posted 2 years ago #

    Hi seregon! I would first recommend taking a look here, as WP can be configured to be used over SSL:
    http://codex.wordpress.org/Administration_Over_SSL

  3. seregon
    Member
    Posted 2 years ago #

    First of all, thank you for the response.

    I am aware of those settings in wp_config.php. As a matter of fact, I've already experimented with them. However, it doesn't address my problem.

    As mentioned in my 4th paragraph above, I'm getting 404 errors when connecting over SSL due to automatic redirects used by the shared SSL configuration on my server. Thus, whether I connect over SSL "manually" (by visiting the wp-admin URL over https) or force it with wp_config settings, the reuslt is the same.

  4. seregon
    Member
    Posted 2 years ago #

    UPDATE

    My hosting provider has provided more info to shine some light on this situation. Basically, the conflict is coming from WordPress respecting, in all cases, the setting I have defined for its URL -- in my case, the subdomain. In general, this is what I want. It's certainly what I want readers to see.

    But obviously this will not work for a secure (SSL) login. Is there a plugin or something to make WordPress distinguish between the URLs for http & https access?

  5. seregon
    Member
    Posted 2 years ago #

    UPDATE 2

    I finally got this sorted out using the WordPress HTTPS plugin [version 1.9.1 on WP 3.2.1]. It has a setting for using a different URL for shared SSL, which is all I need. As an important note, this only works if you check "Remember Me" when you log into Dashboard. Otherwise, you will still have the 404 error.

    As an aside, I also tried the Shared SSL plugin, and it did not work. In fact, it appeared to do nothing at all.

    Hope this helps someone in the future. I'll stay following this thread in case anyone else has questions about my experience.

  6. Mvied
    Member
    Posted 2 years ago #

    Hey Seregon, I'm the developer of WordPress HTTPS. Is the 404 issue when not checking Remember Me on login a bug in my plugin? Perhaps I could take a look at it for you. If you'd like, create a topic at http://wordpress.org/tags/wordpress-https.

  7. seregon
    Member
    Posted 2 years ago #

    Mvied:

    No. I forgot to update this a third time, but in fact that was a weird error with cache/cookies. It does now work with or without "Remember Me" checked.

    I did eventually deactivate this WordPress plugin, due to a few things not working. But I don't think that it's a problem with the plugin (save for maybe one thing), so much as a problem with my extremely limited SSL setup.

    I'm a privacy nut and I'd prefer to be on HTTPS more often than not. Performing admin functions over SSL has some appeal to me. But my shared SSL connection is limited by both bandwidth and the rate of individual requests. Preview links, uploading pictures, and several other crucial functions do not work for me over SSL (nor do I believe they ever will under this arrangement).

    However, I also can't seem to just login over SSL (at least encrypting the transmission of my password) and then switch back to unencrypted. Every time I make that switch I'm asked to log in again, period. I can't do an unencrypted admin session without sending my password unencrypted at least once. That's disappointing and something I wish I could fix.

  8. seregon
    Member
    Posted 2 years ago #

    Incredible. All solidly fixed in v 1.9.2.

    Have I mentioned how strongly I recommend the WordPress HTTPS plugin?

  9. ccolotti
    Member
    Posted 2 years ago #

    I am trying to do something similar and it is not working. What did Bluehost have you configure in your settings to get this to work with an add-on domain?

  10. seregon
    Member
    Posted 2 years ago #

    Hi ccolotti.

    Needless to say, this was a while ago, so I'm working from memory after re-reading this thread. IIRC, I didn't have to configure anything in Bluehost. I tried a few things in WordPress, though mostly I ended up reverting them as the WordPress HTTPS plugin fixed everything for me and rendered my changes moot.

    The big thing is if you're trying to use their shared SSL, you have to access your site as in the sample URL I posted above, i.e.:

    https://secure.bluehost.com/~username/blog/

    where username is whatever you use to login to your cPanel. If you are using the shared SSL, you can't really get it to work with an add-on domain. That is, it won't display your domain in the address bar. The only way to do that would be to buy your own SSL cert (which was needlessly expensive in my case).

Topic Closed

This topic has been closed to new replies.

About this Topic