WordPress.org

Ready to get started?Download WordPress

Forums

Shashin
[resolved] Using Pretty Photo Plugin (8 posts)

  1. todddengler
    Member
    Posted 1 year ago #

    Might be working backwards on this, so bear with me.

    Install Shashin with FancyBox working great, for simple thumbnail galleries as well as the Album viewer.

    Client requested the prettyPhoto modal viewer so we switched to that. The simple thumbnail gallery view worked awesome. However, when we tested the Album viewer (where Shashin pulls in the Album Cover and uses ajax to display the respective gallery) the prettyPhoto script breaks.

    I wonder if you could help me fix this. Possibly manually install Prettyphoto?

    Thanks

    Todd

    http://wordpress.org/extend/plugins/shashin/

  2. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Todd - I can look into this over the weekend. I've been meaning to try integrating prettyPhoto, now that it's GPL.

  3. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    Today I worked on fully integrating prettyPhoto with Shashin. It's going well so far, and I must say pretttyPhoto is nicer to work with than Fancybox. I hope to finish it up this week.

  4. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry it took longer than I expected, but the new version of Shashin now includes prettyPhoto.

  5. gaston909
    Member
    Posted 1 year ago #

    Hmm,

    Switched to the new prettyphoto but when thumbs are clicked it just loads the direct google url

  6. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    I'll need a link to your site so I can diagnose the problem (there is probably a javascript conflict with something else on your site). If you don't want to post it publicly you can send it to me through my contact form - http://www.toppa.com/contact

  7. gaston909
    Member
    Posted 1 year ago #

  8. Mike Toppa
    Member
    Plugin Author

    Posted 1 year ago #

    You have a bunch of javascript errors on your site. I recommend cleaning those up, and it will probably fix this problem. You can take a look with the Developer Tools in Google Chrome. How to access it is here: https://developers.google.com/chrome-developer-tools/docs/overview

    After you open it, click the red x in the bottom right hand corner to see the javascript errors. One of them is from Shashin, but I've never seen that error before - it's probably a downstream effect of one of the other errors already in your theme (or from other plugins).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic