WordPress.org

Ready to get started?Download WordPress

Forums

Using Press It bookmark gives 406 error sometimes (2 posts)

  1. donr
    Member
    Posted 8 years ago #

    Using the Press it bookmark to add a post sometimes results in a

    "Not Acceptable
    An appropriate representation of the requested resource /wp-admin/post.php could not be found on this server."

    error. I have seen a lot of similar posts but no solution (unless you call 'probably a server error' a solution.

    The URL I am posting is http://www.theinquirer.net/?article=28201

    The URL for editing the post - generated by the bookmarklet is

    http://don.robertson.net.nz/wp-admin/post.php?text=&popupurl=http%3A%2F%2Fwww.theinquirer.net%2F%3Farticle%3D28201&popuptitle=Open%20Source%20databases%20rounded%20up%20and%20rodeod

    If I change this URL to

    http://don.robertson.net.nz/wp-admin/post.php?text=&popupurl=http%3A%2F%2Fwww.theinquirer.net%2FFarticle%3D28201&popuptitle=Open%20Source%20databases%20rounded%20up%20and%20rodeod

    that is, if I take out the %3F (?) in the popupurl=http%3A%2F%2Fwww.theinquirer.net%2F%3Farticle%3D28201 (popupurl=http://www.theinquirer.net/?article=28201) part of the URL, it works.

    Seems there could be a problem with /? in the URL?

    Don

  2. AuntiAlias
    Member
    Posted 8 years ago #

    I can confirm this from my recent experience using the bookmarklet and getting a 406 Unacceptable error.

    I sought to press-it with this URL:
    http://www.cnn.com/2006/POLITICS/03/16/congress.debt.ap/index.html?section=cnn_topstories

    and it was rejected. When I removed the ? (?section=cnn_topstories) it worked fine. (But it took some research around here in support forums to even begin to know what was broken and how to fix it)

Topic Closed

This topic has been closed to new replies.

About this Topic