WordPress.org

Ready to get started?Download WordPress

Forums

Google Language Translator
[resolved] Using on SSL pages (3 posts)

  1. curlypinky
    Member
    Posted 6 months ago #

    Thank you for this plugin!

    The plugin will cause non-secure elements errors if it is called on an SSL page.

    A quick fix is to change the lines in the google-language-translator/google-language-translator.php file to remove the "http:" portion of the url from lines that contain src="http://translate.google.com... which will cause the correct prefix to be used depending on the page security. So the urls will look like: src="//translate.google.com...

    Thanks!

    https://wordpress.org/plugins/google-language-translator/

  2. Rob Myrick
    Member
    Plugin Author

    Posted 6 months ago #

    Thanks, curlypinky! Yes it's time to get this changed. It will be provided in the next update.

    I appreciate the feedback, Rob Myrick

  3. Rob Myrick
    Member
    Plugin Author

    Posted 5 months ago #

    This has been fixed in the latest updates - I'm closing this as resolved.

    Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags