WordPress.org

Ready to get started?Download WordPress

Forums

Tiny Forge
[resolved] Using Icon Webfonts (4 posts)

  1. mrhines1
    Member
    Posted 3 months ago #

    Tomas,

    I am looking to add a social media section to my site with links for facebook and twitter.

    I have added a Text widget to the sidebar and included the Icon Webfont code you provided in your "How To" section of the child theme quick start guide.

    However, I am unable to see the icons. If I hover over them I get a tooltip with the title for each and I can even click the area where the icon should be and the link works. It's just that I'm essentially clicking a white box on a white background.

    What am I missing?

    Thank you!

  2. Tomas Mackevicius
    Member
    Theme Author

    Posted 3 months ago #

    Hi, there can be several things.

    If you got that sample code from the readme.txt, you could accidentally copy the ` (backtick) symbol(s), they where added only to make readme file somehow correspond to markdown format.

    If you got that sample code from my website, it includes a new code for the next version, where all web icon font classes start with "el-icon-...". If that's the case, I could send you a beta version of next iteration of theme.

    In any other case I would need to see live website to inspect the problem.

  3. mrhines1
    Member
    Posted 3 months ago #

    I had copied the sample code from the website. I went back and removed the "el-" from the code (so it matches the readme.txt version) and now the icons are visible.

    Thank you!

  4. Tomas Mackevicius
    Member
    Theme Author

    Posted 3 months ago #

    Sure :)

    But please remember, when new version will come out, you will have to add those "el-" prefixes, OK?

    And please share the fruits of your work! :)

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.