WordPress.org

Ready to get started?Download WordPress

Forums

MailPoet Newsletters
[resolved] Using Gmail's SMTP (3 posts)

  1. forward123123
    Member
    Posted 1 year ago #

    First off, I really like this plugin. Thanks for all of the work you do on it.

    I wanted to use Gmail's SMTP instead of my host's PHP mailer because occasionally, mail would be caught up in spam filters. (I had forgotten an old mailer script and it was exploited and now my server is sometimes considered possible spam.)

    I could not get this to work, kept giving me the message that it couldn't connect with Gmail's SMTP. I don't even remember how I found this, just tinkering around.

    The SMTP settings don't work with GMAIL. They are set to SSL and port 465. I had WP SMTP set up, and had tested it earlier on Gmail, and it worked fine. So I used those settings, which are TLS and port 587.

    Now it works fine on Wysija.

    But, I had to go into the plugin files and find the instances of these settings and manually change them. Then I apparently updated the plugin and all of a sudden, I'm getting the can't connect message again.

    I finally remembered that I had done all the changing earlier, so redid all that again. And now it's working fine again.

    For others having the same problem with GMail SMTP, before giving up, you might try this. These files need to be edited:

    helpers/email.php
    helpers/mailer.php
    models/config.php

    just do a search for 465 and you'll find that plus 'ssl'

    Change 465 to 587 and ssl to tls in those three files.

    It worked for me. I don't know if this is something set up on my host, or if it's a gmail thing.

    For future updates, it might not be a bad idea to add something in the settings that the user can use, to change these two values if they're having problems getting SMTP to work.

    http://wordpress.org/extend/plugins/wysija-newsletters/

  2. forward123123
    Member
    Posted 1 year ago #

    Yikes, I've obviously screwed something up this time. It's sending two copies of the email asking subscribers to confirm.

    Any ideas?

  3. Ben
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Logically
    there is not need to change the port from within the code, you can simply go to Wysija > Settings > Send With ... and select the Third Party option. This way you will be able to use gmail or any SMTP service and specify the port of your choice, and the authentication you want.

    Cheers,
    Ben

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags