WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Using fullcalendar shortcode (10 posts)

  1. charles@quince.us
    Member
    Posted 10 months ago #

    Hello all,

    I am attempting to use a shortcode to display an event calendar on a home page. I have installed WP Fullcalendar, and am using the following in index.php: <?php echo do_shortcode('[fullcalendar]'); ?>.

    Nothing appears on the page, and there are no errors. (I'm using Firebug.)

    I've tried specifying the type (event), and no luck.

    Any help would be appreciated.

    http://wordpress.org/plugins/events-manager/

  2. charles@quince.us
    Member
    Posted 10 months ago #

    Update:

    Here's what is generated by the shortcode. Nothing appears on the screen:

    <div id="wpfc-calendar-wrapper">
    <form id="wpfc-calendar"></form>
    <div class="wpfc-loading"></div>
    </div>
    <div id="wpfc-calendar-search" style="display:none;"> </div>
    </div>

    Thanks.

  3. caimin_nwl
    NetWebLogic Support
    Posted 10 months ago #

    Do you have Override calendar shortcode? set to Yes under Events > Settings > General > Full Calendar Options?

  4. charles@quince.us
    Member
    Posted 10 months ago #

    Yes. I've tried both ways. (And thanks for responding!)

  5. charles@quince.us
    Member
    Posted 10 months ago #

    I tried creating a post with the included shortcode. No luck. Same markup is generated, but nothing is visible on the page.

  6. charles@quince.us
    Member
    Posted 10 months ago #

    Because something is generated by the shortcode, it seems like the place to start looking is what comes after. Is there an ajax call to get the calendar? I don't see any failures, so perhaps there is some other reason why this fails. Maybe all I need is a place to look that might help me unravel this.

  7. caimin_nwl
    NetWebLogic Support
    Posted 10 months ago #

    I'd start by deactivating all other plugins and switching to the default theme, to see if there's a javascript conflict causing the problem.

  8. charles@quince.us
    Member
    Posted 10 months ago #

    This should be the correct syntax?

    [fullcalendar type="event"]

    I've tried with and without the type attribute, which seems redundant since I've defined this within the config pages. I've tried "events_fullcalendar" as well. Same result.

    Also, I'm going to step through the code that tries to render this section and see what's going on. The only other plugin I'm using is EM, so it would be odd if that were the issue.

    If you have any other suggestions, please pass them on!

  9. charles@quince.us
    Member
    Posted 10 months ago #

    In following the code, I find this in wp-fullcalendar.php:
    do_action('wpfc_calendar_search', self::$args);

    I tracked 'wpfc_calendar_search' to em-wpfc.php. There I find this:

    //this never worked because the action was never correctly called, until we add a setting for this in the options page, uncomment the line below or paste it in your functions.php file
    //add_action('wpfc_calendar_search','wpfc_em_calendar_search', 10, 1);

    Is this a problem? I can't find the action referenced or defined in any other php file. Where else might I look?

  10. angelo
    NetWebLogic Support
    Posted 10 months ago #

    if your theme supports widget on homepage you can use text widget then add fullcalendar shortcode.

    you can add this in your theme functions.php to enable shortcode in text widget - add_filter('widget_text', 'do_shortcode');

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.