WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Using Dreamweaver CS6 with Bitnami WordPress (6 posts)

  1. SimplyWander
    Member
    Posted 1 year ago #

    I am trying to get Dreamweaver setup to do dynamic editing of my WordPress files installed on my desktop with Bitnami.
    My Bitnami WordPress Stack is installed to the following link: C:\WordPress\BitNami WordPress Stack\ and the path to the index.php is: C:\WordPress\BitNami WordPress Stack\apps\wordpress\htdocs

    To setup Dreamweaver local site, I'm using the following settings: Server Name: Bitnami Connect Using: Local/Network Server Folder: C:\WordPress\BitNami WordPress Stack\apps\wordpress\htdocs\ Web URL: http://127.0.0.1 8080/ (I've also tried it omitting the '8080/') (I've also tried the Web URL http://127.0.0.1/wordpress/) and, under the 'Advanced' tab, I'm using the Server Model: PHP MySQL

    My problem is that when I open the index.php file in Dreamweaver's main window (split view) I do see the code on the left side of the page, but on the right side of the page (the 'design' side) all I get is a blank (white) box. When I try to open another page - for example wp-blog-header.php - the same thing happens (code on left, blank box on right).

    When I try to open single.php, I get code on the left and the box on right has small symbols stating 'PHP' but no real design is visible and I get an error message on top of the screen that states 'Dynamically-related files could not be resolved because of an internal server error. Retry.'

    I have my permalinks in WordPress set to default, as I have read that failure to do so has caused problems in Dreamweaver in other people's installations.

    Can anyone help me out? Why am I not getting a dynamic preview?

  2. SimplyWander
    Member
    Posted 1 year ago #

    I finally got a live view by re-installing Bitnami (unfortunately I lost all the posts and images stored in the MySQL database when I did the re-install) and by using the following settings for the Dreamweaver site manager:

    Local Site Folder - C:\WordPress\apps\wordpress\htdocs

    Local Server Folder - same as local site folder

    Web URL: http://127.0.0.1/wordpress/

    Now, when I connect using the 'split' 'live' buttons under the 'Designer' view, and open the index.php file, I see the actual code on the left side of the split screen and the front page of my website on the right ('live') side of the split screen. HOWEVER, I still get an error message above the two split screens that states 'Dynamically-related files could not be resolved because the site definition is not correct for this server'. I have no idea what this means, or how to correct it.

    I'd greatly appreciate any help that you, victor, or anyone could give. Thanks

  3. Peter
    Member
    Posted 1 year ago #

    That error message looks like and adobe dreamweaver message.

    If you are using the MAMP default ports, use http://localhost:8888/ for the URL.

    You can try clicking on advanced settings for the Dreamweaver site manager :
    For the Server Model (in the Testing Server section) select PHP MySQL

    Adobe have a step by step on the settings here:
    http://www.adobe.com/devnet/dreamweaver/articles/setup_php.html

    They are recommending XAMPP I too would recommend that over bitnami!

  4. SimplyWander
    Member
    Posted 1 year ago #

    To anyone/everyone who eventually ends up reading this thread, I FINALLY got Dreamweaver to work correctly with my Bitnami WordPress installation. Purely a trial and error process on my part, but I now actually can get a live view of my website from index.php, page.php, etc. on my laptop server - and without any persistent error messages.

    Here's how I did it (the pathways to my Bitnami WordPress installation are C:\WordPress\apps\wordpress for the wordpress installation, and C:\WordPress\apache2 for the server install):

    From Dreamweaver, press the 'Site' tab, and then select 'new site'
    Type in the desired site name (mine I used 'SimplyWander')
    Type in your local site folder where your Bitnami WordPress installation resides (in my case 'C:\WordPress\apps\wordpress\'
    Now hit the 'servers' tab in the upper left corner of this same screen
    On the 'Basic' popup window, enter the following info a. server name (the local bitnami server) - I just used 'Bitnami' b. Connect Using - use the drop down to select 'Local/Network' c. Server folder - use the same folder as the local site folder in step (3), not the pathway to the apache2 server (in my case, the value entered here is 'C:\WordPress\apps\wordpress\' d. web URL: http://127.0.0.1/wordpress/
    Then hit the 'Advanced' tab at the top of the popup window, and use the dropdown menu to change Server Model to 'PHP MySQL'. Hit 'Save'.
    Uncheck the box that says 'remote' and then check the box that says 'testing'
    Hit 'save' and then 'done'. That's it - the local testing site is setup to work with Dreamweaver.
    There is one other thing to be done. Dreamweaver for some reason won't work with any permalink structure other than the 'default'. Go into your Bitnami WordPress installation dashboard, and under the permalinks tab, change the setting to 'default'.

    Now everything should work with regards to php files (it does for me). Under the 'designer' screen in Dreamweaver, you can now select the 'split' and 'live' buttons, and see code on one side and the live screen from your website on the other. The 'live code' and 'inspect' buttons will also work.

  5. acsweeney
    Member
    Posted 1 year ago #

    I also had a brutal time, started with Wamp. Never quite made it. Bitnami windows vista Multisite working, with much tweaking with hosts file and others, did not work with Dreamweaver.

    Anyway, My laptop crashed on me, and I'm reinstalling all of it again! Cleanly, and hoping for a glimmer of hope... If I find one I'll come back.

  6. ghaden
    Member
    Posted 9 months ago #

    I'm feeling this pain of setting this up with Dreamweaver too.. any good guides for this?

Topic Closed

This topic has been closed to new replies.

About this Topic